Error 502 Request Error

Hi,
I have a problem when start my local server and try to go on my website. I obtain the follow error:


I didn’t understand what is the problem. This is the error logs, thank you for your support.

2024/03/09 19:09:37 [warn] 1054#0: *6756 a client request body is buffered to a temporary file /Users/mario/Library/Application Support/Local/run/router/nginx/client_body_temp/0000000022, client: ::1, server: carlottaderosa.local, request: "POST /wp-admin/post.php HTTP/1.1", host: "carlottaderosa.local", referrer: "http://carlottaderosa.local/wp-admin/post.php?post=1918&action=edit"
2024/03/09 19:10:46 [warn] 1054#0: *6848 a client request body is buffered to a temporary file /Users/mario/Library/Application Support/Local/run/router/nginx/client_body_temp/0000000023, client: ::1, server: carlottaderosa.local, request: "POST /wp-admin/post.php?t=1710007777237 HTTP/1.1", host: "carlottaderosa.local", referrer: "http://carlottaderosa.local/wp-admin/post.php?post=1918&action=edit"
2024/03/09 19:11:01 [warn] 1054#0: *6952 a client request body is buffered to a temporary file /Users/mario/Library/Application Support/Local/run/router/nginx/client_body_temp/0000000024, client: ::1, server: carlottaderosa.local, request: "POST /wp-admin/post.php HTTP/1.1", host: "carlottaderosa.local", referrer: "http://carlottaderosa.local/wp-admin/post.php?post=1918&action=edit"
2024/03/09 19:18:28 [warn] 1054#0: *9041 a client request body is buffered to a temporary file /Users/mario/Library/Application Support/Local/run/router/nginx/client_body_temp/0000000025, client: ::1, server: carlottaderosa.local, request: "POST /wp-admin/post.php HTTP/1.1", host: "carlottaderosa.local", referrer: "http://carlottaderosa.local/wp-admin/post.php?post=2002&action=edit"
2024/03/09 19:18:30 [warn] 1054#0: *9050 a client request body is buffered to a temporary file /Users/mario/Library/Application Support/Local/run/router/nginx/client_body_temp/0000000026, client: ::1, server: carlottaderosa.local, request: "POST /wp-admin/post.php HTTP/1.1", host: "carlottaderosa.local", referrer: "http://carlottaderosa.local/wp-admin/post.php?post=2002&action=edit"
2024/05/17 19:07:53 [error] 1553#0: *1 kevent() reported that connect() failed (61: Connection refused) while connecting to upstream, client: ::1, server: carlottaderosa.local, request: "GET / HTTP/1.1", upstream: "http://127.0.0.1:10003/", host: "carlottaderosa.local"
2024/05/17 19:07:54 [error] 1553#0: *4 kevent() reported that connect() failed (61: Connection refused) while connecting to upstream, client: ::1, server: carlottaderosa.local, request: "GET /apple-touch-icon-precomposed.png HTTP/1.1", upstream: "http://127.0.0.1:10003/apple-touch-icon-precomposed.png", host: "carlottaderosa.local"
2024/05/17 19:07:54 [error] 1553#0: *4 kevent() reported that connect() failed (61: Connection refused) while connecting to upstream, client: ::1, server: carlottaderosa.local, request: "GET /apple-touch-icon.png HTTP/1.1", upstream: "http://127.0.0.1:10003/apple-touch-icon.png", host: "carlottaderosa.local"
2024/05/17 19:07:54 [error] 1553#0: *1 kevent() reported that connect() failed (61: Connection refused) while connecting to upstream, client: ::1, server: carlottaderosa.local, request: "GET /favicon.ico HTTP/1.1", upstream: "http://127.0.0.1:10003/favicon.ico", host: "carlottaderosa.local", referrer: "http://carlottaderosa.local/"
2024/05/17 19:08:32 [error] 1553#0: *8 kevent() reported that connect() failed (61: Connection refused) while connecting to upstream, client: ::1, server: carlottaderosa.local, request: "GET / HTTP/1.1", upstream: "http://127.0.0.1:10003/", host: "carlottaderosa.local"
2024/05/17 19:08:39 [error] 1553#0: *10 kevent() reported that connect() failed (61: Connection refused) while connecting to upstream, client: ::1, server: carlottaderosa.local, request: "GET / HTTP/1.1", upstream: "http://127.0.0.1:10003/", host: "carlottaderosa.local"
2024/05/17 19:09:03 [error] 1658#0: *1 kevent() reported that connect() failed (61: Connection refused) while connecting to upstream, client: ::1, server: carlottaderosa.local, request: "GET /wp-admin/ HTTP/1.1", upstream: "http://127.0.0.1:10003/wp-admin/", host: "carlottaderosa.local"
2024/05/17 19:09:29 [error] 1725#0: *1 kevent() reported that connect() failed (61: Connection refused) while connecting to upstream, client: ::1, server: carlottaderosa.local, request: "GET / HTTP/1.1", upstream: "http://127.0.0.1:10003/", host: "carlottaderosa.local"
2024/05/17 19:11:34 [error] 1076#0: *1 kevent() reported that connect() failed (61: Connection refused) while connecting to upstream, client: ::1, server: carlottaderosa.local, request: "GET / HTTP/1.1", upstream: "http://127.0.0.1:10003/", host: "carlottaderosa.local"

Hi @mariototaro

Can you try changing your Router Mode and see if that fixes it?

Preferences>Advanced>Router Mode