Error installing on Windows 8.1 64bit

Iv’e downloaded the 2.1.2.

tried everything, uninstalled few apps, no change.
this is the log:

Dec 30, 2017, 9:00 PM GMT+2 - info: [main/docker-create-machine] USING IP:
Dec 30, 2017, 9:00 PM GMT+2 - info: [main/docker-create-machine] Removing existing Docker Machine
Dec 30, 2017, 9:00 PM GMT+2 - info: [main/docker-create-machine] null ‘About to remove local-by-flywheel\nWARNING: This action will delete both local reference and remote instance.\n’ ‘Error removing host “local-by-flywheel”: Host does not exist: “local-by-flywheel”\nCan’t remove “local-by-flywheel”\n’
Dec 30, 2017, 9:00 PM GMT+2 - info: [main/docker-create-machine] Creating Docker Machine… --virtualbox-boot2docker-url=file://C:\Users\ASUS\AppData\Local\Programs\local-by-flywheel\resources\extraResources\virtual-machine\vendor\docker\boot2docker.iso
Dec 30, 2017, 9:00 PM GMT+2 - info: [main/docker-create-machine] Creating machine with
[ ‘create’,
‘local-by-flywheel’ ]
Dec 30, 2017, 9:00 PM GMT+2 - error: [main/docker-create-machine] dial-http tcp read tcp> wsarecv: An existing connection was forcibly closed by the remote host.
Dec 30, 2017, 9:01 PM GMT+2 - info: [main/docker-create-machine] Unable to create Docker Machine.

then tried to install v 2.2.1, same problem.
here is the log:
local-by-flywheel.log (2.5 KB)

Hi @benheller,

Thanks for the log!

Can you try upgrading to VirtualBox 5.2.4? Here’s the direct download link:

After doing that, please try re-opening Local.

Hi @clay,

I have tried to upgrade to VirtualBox 5.2.4, tried many things icluding playing with the Virtualbox network settings, tried with disabled wifi and NOTHING!.

i thought that the problem is concerned to the fact that i’m connecting through WiFi and Local is not getting IP form VM because of that… maybe i’m wrong.
i saw in the community that many people have the same issue with the network settings and that Local is not getting an IP from the VM.

here are some logs one of the is with my /*comments.

old.local-by-flywheel.log (8.3 KB)

local-by-flywheel.log (20.8 KB)

I have spent too much time trying to find a solution for this problem, I hope that you will find a way to fix it a.s.a.p.

thank you.



Thank you for the logs and info.

Can you please open VirtualBox and check if there’s a local-by-flywheel VM?

Warning for existing Local users, the instructions below will remove the Local VM and is potentially destructive with existing Local sites.

If so, right-click on it and go to “Remove” and then select the option to remove all files. Once you do that, re-open Local.

i have removed local from the VM.
opened Local and started the host installation. then got this error msg: dial-http tcp read tcp> wsarecv: An existing connection was forcibly closed by the remote host.

here is the log:

actually i did all of that yesterday, the minute that you stop the VM session or change something or delete local from the VM, Local can’t install or use the Docker Machine. and the only thing that is helping is to uninstall everything inc. the settings inside the VM. but it stays in the same condition again and again.
see the logs and understand.

local-by-flywheel.log (22.9 KB)


I have uninstalled and installed again…

stage 1: ok.

stage 2: installing the host on VM…

then it gets stuck and the log says:
Jan 4, 2018, 10:49 PM GMT+2 - info: [main/docker-create-machine] (local-by-flywheel) Waiting for an IP…local-by-flywheel.log (3.8 KB)

that why i thought that it concern to my Wifi connection.

Hi @benheller,

I know it’s late there, but did it get past that step?

Depending on your PC setup, that Waiting for an IP... step can take up to 10 minutes.

as i said before it get stuck. and after some time i get this massage: “Error creating machine: Error in driver during machine creation: Maximum number of retries (5) exceeded”local-by-flywheel.log (4.3 KB)

Did you see any UAC prompts asking for permissions from VirtualBox/Oracle during that process?

Also, it may be worth restarting your computer if you haven’t done it in a while. The VirtualBox networking drivers sometimes require a restart on Windows. Once you restart your computer, you can delete the local-by-flywheel VM again and retry installation if you have time.

So sorry for the trouble!

First of all i want to thank you for the help !

yes, i had 2 prompts. after them it installed local in the VM.
i have restarted the computer many times.
i will do it again for you.

Hi @clay !

I have restarted and deleted from the VM.
opened Local and had 2 prompts from VM.
same as before, local is wating for an IP and again this error…:

local-by-flywheel.log (9.1 KB)

maybe it is something with the adapter settings for the host??

Hi @clay !

there is any solution for the issue? i will be happy to use your software.

Hi Ben,

Unfortunately, the VirtualBox errors aren’t revealing much information.

Can you try the following?

  1. Quit Local if it’s running
  2. Open VirtualBox
  3. Click “Global Tools”
  4. Remove any “Host-only Networks” that you see under “Host Network Manager”. Their names will be something along the lines of vboxnet0
  5. Delete the local-by-flywheel VM if it’s present under “Machine Tools” (warning to current Local users: do not do this unless you have a good reason. You will need to restore your existing sites.)
  6. Re-open Local

Hi @clay !

I did everything but it stays the same…
please let me know if there is something to do.

local-by-flywheel.log (4.0 KB)