Error on DB import with Adminer

What issue or error are you experiencing?

Error on import of db (~ 350mb in size)

Fatal error : Allowed memory size of 268435456 bytes exhausted (tried to allocate 321598096 bytes) in /Applications/Local.app/Contents/Resources/extraResources/adminer/adminer.php on line 100


Is this an issue with memory allocation, and if so, how can I address it? Thank you! :pray:


System Details

  • Local Version:
    Version 9.0.2+6676

  • Operating System (OS) and OS version:
    macOS Sonoma 14.2.1

For further context…

Hi @kerns

You should still be able to manually import the database as a workaround using the steps here:

Hi @kerns

Another update here as I have been working with another user getting the same error. More details and a feature request to follow here:

2 Likes

Thanks, @Nick-B – but why isn’t it possible to edit a file somewhere as a quick fix? :thinking: I will try the other method suggested but I’m just curious.

It’s just not something that we have made publically accessible yet, so that’s why we created the feature request :slight_smile:

Similar to PHP memory, we’d rather not just “blanket raise” the value in Local to something super high but give the ability to users to raise as they need down the road.

Thx @Nick-B – but as a temporary workaround, is it not possible to find an ini or config file and manually edit it? Is it compiled somehow in a way that makes it inaccessible? I will try the other method …but I am not sure it will work.

Yes that is the goal of the feature request is to make it publically accessible because currently it is not unlike the PHP memory which you can access and edit.

1 Like