Error trying to start site that was working yesterday. Uh-oh! Unable to start site

What issue or error are you experiencing?

Uh-oh! Unable to start site

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Tried to start a site that was working just yesterday

System Details

  • Local Version:
    Version 8.1.0+6514

  • Operating System (OS) and OS version:
    Windows 11

Local Logs

local-lightning.log (890.4 KB)

Some background. I recently upgraded local and when I did, the php version for the site was empty. So I selected one of the new version in the drop down and things seemed ok until this morning when I went to run the site I got an uh-oh. I noticed the php version was empty again so I selected the one that was downloaded before, but still getting the error. Looking at PHP logs I see things like this…

PHP Startup: Unable to load dynamic library ‘php_pdo_mysql.dll’ (tried: C:/Users/sleek/AppData/Roaming/Local/lightning-services/php-8.2.10+1/bin/win64/ext\php_pdo_mysql.dll (The specified procedure could not be found)

Looking at that location the file is there, though its a little strange that the last slash in the path is the opppsite direction from the others.

Hi @sleekdigital

If you create a new, blank site in Local can you access that okay? If you can, then you may want to try reimporting the site getting the errors. The steps would look like this:

  • Locate the site files on your machine, and save a copy of them to your desktop. If you click Go to Site Folder under your site name it should take you right to where they are located.
  • Once you have those copied, completely delete the site from Local
  • Restart Local/your machine
  • Reimport the site back into Local. You can refer here on how to Restore from only Local site files

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.