Error: WordPress installation failed + can't connect to database

Hello, I just installed local and set up a new site but I’m getting the error message saying ‘Wordpress installation failed’.

I can’t find any way of re-installing/fixing.

I also can’t login to the database in adminer using the given default values:
‘Access denied for user ‘root’@‘localhost’ (using password: YES)’

Nor does the Wordpress database set-up work.

Please advise. Thanks.

Sorry for the trouble!

Have you tried creating the site multiple times? Does it happen each time?


This is happening to me. I have tried 3 sites now and all do the same thing. I even made nginx and apache. Any thoughts?

Same here. I have had issues from the start, but lately, I can’t create a single site without wordpress installation failing. Starting to be glad I still have my old server in place. Tried apache and nginx as well. It just sits on wp install for about an hour, and then it fails.

No way to fix it.

Same problem here

Hi Clay,

I’ve tried just about everything - deleting, new sites, new names, re-installing the app, installing WordPress manually, etc, etc, all with no success.

Any ideas on a fix? Currently this issue makes the app unusable and I’m very keen to get it working as it looks great! Thanks.

Hey @fryder,

Have you tried Local 1.4.1?

Still failing to install WordPress on 1.4.2 - the only way I can use this app is to manually complete the WordPress install or set up a site from a blueprint.

What do I need to do?

Im getting the same issue. Is there a fix?

1.4.2 works. Thank you.

1 Like

Same problem here. If it’s not one issue, it’s another.

Same problem here. Loads of threads about this but it seems no solution?

Hi everyone. I solved this problem by updating VirtualBox. I’m on MacOS.

Error! WordPress installation failed. Looking at database tab, I see "Unable to find DB_HOST in app/public/wp-config.php for Host, Database name,etc.

Worked to set up several WordPress sites a week or two ago. Now no on several tries.

Windows 7; Local version: 2.2.4. recently updated VirtualBox.

Is this the same problem or should I start a new thread?

How do I update VirtualBox?