HELP: MySql error issue Error establishing a database connection, missing MLOG_CHECKPOINT, "Uh-oh! MySQL was unavailable

Upon researching online it appears that I have a MySql problem. There is entry halfway down in error log " missing MLOG_CHECKPOINT between the checkpoint 78356106 and the end 78355968" Is there an easy way to fix this, I have no database experience and prefer not to modify files. I tried multiple restarts of Flywheel and virtual machine. I can create new site which works fine. BTW, I use Flywheel for local development at this time.


Error establishing a database connection
This either means that the username and password information in your wp-config.php file is incorrect or we can’t contact the database server at localhost . This could mean your host’s database server is down.
Are you sure you have the correct username and password?
Are you sure that you have typed the correct hostname?
Are you sure that the database server is running?
If you’re unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.


Uh-oh! MySQL was unavailable when Local tried to back up … database
2019-09-02T05:50:16.546998Z 0 [Note] /usr/sbin/mysqld: Shutdown complete

CONTENT OF: /logs/mysql/error.txt Halfway down in bold I have highlighted error

2019-09-02T05:50:18.375034Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).

2019-09-02T05:50:18.375462Z 0 [Note] /usr/sbin/mysqld (mysqld 5.7.23) starting as process 2476 …

2019-09-02T05:50:18.387694Z 0 [Note] InnoDB: PUNCH HOLE support available

2019-09-02T05:50:18.387892Z 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins

2019-09-02T05:50:18.388020Z 0 [Note] InnoDB: Uses event mutexes

2019-09-02T05:50:18.388131Z 0 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrier

2019-09-02T05:50:18.388240Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.3

2019-09-02T05:50:18.388348Z 0 [Note] InnoDB: Using Linux native AIO

2019-09-02T05:50:18.389017Z 0 [Note] InnoDB: Number of pools: 1

2019-09-02T05:50:18.389329Z 0 [Note] InnoDB: Using CPU crc32 instructions

2019-09-02T05:50:18.392464Z 0 [Note] InnoDB: Initializing buffer pool, total size = 32M, instances = 1, chunk size = 32M

2019-09-02T05:50:18.399464Z 0 [Note] InnoDB: Completed initialization of buffer pool

2019-09-02T05:50:18.401292Z 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().

2019-09-02T05:50:18.416950Z 0 [Note] InnoDB: Highest supported file format is Barracuda.

2019-09-02T05:50:18.417933Z 0 [ERROR] InnoDB: Ignoring the redo log due to missing MLOG_CHECKPOINT between the checkpoint 78356106 and the end 78355968.

2019-09-02T05:50:18.418120Z 0 [ERROR] InnoDB: Plugin initialization aborted with error Generic error

2019-09-02T05:50:19.034434Z 0 [ERROR] Plugin ‘InnoDB’ init function returned error.

2019-09-02T05:50:19.034633Z 0 [ERROR] Plugin ‘InnoDB’ registration as a STORAGE ENGINE failed.

2019-09-02T05:50:19.034745Z 0 [ERROR] Failed to initialize builtin plugins.

2019-09-02T05:50:19.034850Z 0 [ERROR] Aborting

2019-09-02T05:50:19.034955Z 0 [Note] Binlog end

2019-09-02T05:50:19.035144Z 0 [Note] Shutting down plugin ‘CSV’

2019-09-02T05:50:19.036534Z 0 [Note] /usr/sbin/mysqld: Shutdown completestrong text

Hey @cerdt113387

That sort of error usually means that the database has been corrupted in some way which is why the site is having problems.

The easiest thing to do would be to restore the site from a backup into a new Local site. You can try using the files for the site by following the steps outlined in the “Restoring From Only Local Site files” section of this help doc:

If that doesn’t work, then you might have a look at this post in the forums, which links to some additional resources on StackOverflow: