HELP PLEASE! Missing hosts entry. WINDOWS 7

Hi i install the lasts versions of Flywheel and VirtualBox and i have an error when i select my site. I get the error "Warning missing hosts entry. This site may be inaccesible. Then when i put FIX IT says something with node-windows.exe and then i put OK its says another error "Local ran into a problem when trying to update the hosts file. I am using Windows 7 home Premium and i dont have any antivirus or somethinglike Gas Mask activated.

Hi Gaston,

Can you please try it again and then provide the entire error that pops up in the error dialog after clicking “Fix It”?

Sorry for the trouble!

Hi Clay, thanks for the fast reply, here are the errors that i get.



Do you have any type of anti-virus, internet security suite, or firewall installed other than Microsoft Defender?

No, nothing of that.

HELP PLEASE? I don’t know what happen.

Can you please check if the hosts file is set as read-only? See Help! I'm running into an EPERM error with the hosts file on Windows

Is not for read - only

1 Like

I apologize but I missed your first screenshot with the error in Spanish.

It looks like node-windows.exe is missing or the wrong path is being used.

Can you try upgrading to Local 2.1.1? You can find the download link here: Local by Flywheel 2.1.1

I updated 2.1.1 and same error.

Hi evryone
I’ve a similar problem on Windows 8.1
“EPERM error with the hosts file on Windows”
I’ve try the solution of clay with “hosts” properties but “Read-only” was already uncheck and the error message always done
Could you help me please


Are you running any anti-virus, internet security, anti-malware, or firewall other than Microsoft Defender? It may be locking the hosts file thus causing the EPERM error.

I dont have nothing of that :S

Can you open Cmd.exe and run the following command? It’ll create a file named hosts file info.txt on your Desktop. Please attach it here after you run the command.

wmic datafile where name="C:\\Windows\\System32\\drivers\\etc\\hosts" > "%UserProfile%\Desktop\hosts file info.txt"

That was not necesesary i think that was the windows defender of windows 7 that is ocult, so i desactivated and now works!!! thanks for all clay!! And sorry for your time expended on me, thank you very much again :smiley: !!

1 Like

For my part, I have another antivirus: Kaspersky
how do I proceed ?
thanks in advance Clay :slightly_smiling_face:

@clay It seems that I have a similar issue on windows 10 with local for flywheel version 2.1.1.
I can see the warning that says “Warning! Missing hosts entry. This site may be inaccessible.” - and after I click “Fix it” button the following error notifications pops up:

and after clicking OK on this error pop up, the following one appears:

Any help would be appreciated, I tried to reinstall flywheel, which didn’t help, I also disabled BitDefender firewall to see if this would change something but still the same errors. I run out of ideas of what should I do to fix it.

This is my log file in case this would be helpful:
local-by-flywheel.log (112.4 KB)

We need help about this error message on Windows 8 or 10
Could you answer us please

Hi All,

Have you tried running local as an administrator?




Please try temporarily disabling Kaspersky. If that fixes the issue, please re-enable Kaspersky and try the following:

  1. Open Kaspersky
  2. Go to Settings » Threats & Exclusions » Exclusions » Settings
  3. Go to Add » Select file or Folder and select C:\Windows\System32\drivers\etc\