Help...Stuck Since Friday: White Screen When Opening New Sub Domain

Hi, I’m pretty stuck. Can’t and don’t want to do anything more until I can solve this. Would hate to put a lot more work into building a site to find out there is a major problem. This is what’s happening:

  1. I created a multisite/subsite installation adding 7 sub domains. I have 4 plugins installed and one high quality paid for theme.
  2. Building one at a time. The first four seem to work perfectly. When I try to open number 5 the browser freezes then I get a white screen. I cannot access the front or backend.
  3. I’ve deactivated the 4 plugins and theme, still nothing.
  4. I deleted the sites that won’t open and created a new sub domain, still won’t open.
  5. I created a new multisite installation and added 3 sub domains to see if the problem pops up again and it does. I can open site number 1 but not sub domains 2 & 3.

The crazy thing is on the first multisite, the primary and three subdomains work fine.

I need a multisite with 7 sub domains. I’m not sure what to do. I’ve read everything I could find online but still haven’t been able to find a solution. Do you have any thoughts?

Thanks, Carol

I’m getting this error message in my admin area. I’m not sure if it is related:

Warning: An unexpected error occurred. Something may be wrong with or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to Please contact your server administrator.) in /app/public/wp-includes/update.php on line 384

Hey Carol,

There are many things involved here, but let’s make a plan to understand what’s going on.

Wordpress multisite has no limitation, so that’s not an issue, but there are limitations that come from various other sources… Domains, hardware, and such.
This error most times happen because there was a problem when the site tried to communicate with Wordpress servers.

  1. First thing to ask is, what are the domains you are using on Local? Some domains might not work because of special characters or something like that.
  2. Would be good to check if your computer can really handle 7 sites running at the same time. I’m not aware of any limitation from Local for that.
  3. Install the plugin Health Check (Health Check & Troubleshooting – WordPress plugin | and see if there’s anything suspicious there, you can send us what’s printed there too.
  4. There is a weird fix that I found here on the forum that says to switch the server to nginx and back to Apache, if you need help with that let me know. This is the topic:
  1. Can you provide your Local log and your Apache/nginx log? To get the Apache/nginx log, you go to `~/Local Sites/yourmultisite/logs/apache and nginx. You can send the error.log from both folders if you don’t know what is being used on the environment. To get the Local log follow this:

Let’s follow this path first, and we’ll have more information about the problem to be able to pin point a solution :wink:

Hi again, I installed this plugin. What information should I send to you or relay to you? And, I just updated my network after updating my theme and this is the error message:

Warning! Problem updating http://extreme-adventure.bizolly.local. Your server may not be able to connect to sites running on it. Error message: cURL error 28: Resolving timed out after 10525 milliseconds


On the plugin (Health Check) see if there is any errors, or something that the plugin marked as a problem. It analyses a lot of variables on the server and Wordpress installation in order to see if everything would work properly.

But I have a solution that might solve it.
This cURL problem some times is tied to PHP configuration limit of memory.This is the process:

  1. Find the file php.ini inside ~/Local Sites/yourmultisite/conf/php/*php-version*/ and open it on any text editor, or IDE you might use.
  2. In this file, you will search for three directives and change their value:
  • memory_limit = 256M
  • max_input_vars = 10000
  • post_max_size = 100M

Change those options, save the file and restart the website on Local.
See if it works now, if not, we can continue!

Here is something plugin found:

PHP Extensions * The optional module, libsodium, is not installer, or has been disabled.

  • The required module, mcrypt, is not installer, or has been disabled.

I don’t find: conf/php/php-version

I have: local site/bizolly/either: logs or app/
In app/either: sql or public/
In public/don’t have a php.ini file

Using health check plugin this info it gives regarding php will it show me the location of this file?

PHP Extensions * The optional module, libsodium, is not installer, or has been disabled.

  • The required module, mcrypt, is not installer, or has been disabled.

Probably not the problem, but we might visit this again if the problem persists.

I don’t find: conf/php/ php-version

Inside the “php” folder probably will have only one folder, with the version number (5.6, 7.1.4, 7.2, something like that) that is the folder you’ll find this configuration file.

I have: local site/bizolly/either: logs or app/

Ok, this means you are using the Preferred Environment. I suggest you to change to the Custom Environment:


Beside the “Local Environment” click on “Change” and select Custom, hit “Save changes” and wait the update to be made.
After you do this, try to make this process I said before. Changing to the custom environment will make the folders I spoke to appear on the folder structure.

I just changed to custom. Hope this doesn’t cause the site to crash! :stuck_out_tongue_winking_eye:

All is good.

It shouldn’t, the basic difference of them appear to be that the preferred is a premade setting, and the custom, you can edit every aspect of the environment.

I recommend you to use PHP 7.1 or 7.2.

I have completed the changes to the php.ini file and turned off local and restarted but still its not working.

Can you see if you can provide the logs now, then?
Adding to the Apache/nginx logs, you can provide the PHP logs too, it will be inside the “logs” folder, under php/*version-number*

Its telling me I am using php 7.0.3 how do I change this? Do you want me to provide them to you as an attachment?

1 Like

Yes! As an attachment here.

To change it, you need to click “Change” on the Local Environment, and select a version:



[25-Mar-2019 18:34:55] NOTICE: fpm is running, pid 678
[25-Mar-2019 18:34:55] NOTICE: ready to handle connections
[25-Mar-2019 18:39:29] NOTICE: fpm is running, pid 542
[25-Mar-2019 18:39:29] NOTICE: ready to handle connections

the error log is pretty long


Only the “error.log” log files are needed! :smiley:

the error log is pretty long

That’s exactly the reason why we need it haha the information about all the errors will be there, and this can lead us to understand what’s happening.

This is error log:

error.log (2.6 KB)

This is error log:

This file shows that maybe there is a table missing from Wordpress structure for some reason. This can be something with the name of the site, or its slug when creating.

Can you provide the other logs I spoke before?
Apache/nginx and Local log


Apache folder: empty
Nginx error log:

2019/03/25 18:50:49 [emerg] 738#0: bind() to failed (98: Address already in use)
2019/03/25 18:50:49 [emerg] 738#0: bind() to failed (98: Address already in use)
2019/03/25 18:50:49 [emerg] 738#0: bind() to failed (98: Address already in use)
2019/03/25 18:50:49 [emerg] 738#0: bind() to failed (98: Address already in use)
2019/03/25 18:50:49 [emerg] 738#0: bind() to failed (98: Address already in use)
2019/03/25 18:50:49 [emerg] 738#0: still could not bind()

Where is Local error log? I followed instructions: ~/Library/Logs/local-by-flywheel.log

I don’t see this.

On this link I provided: How do I retrieve Local's log file? - FAQ - Local Community
There is an option on the app to open the log (Help > Reveal Local’s Log):

It’s an easy way to do it :slight_smile:

Also, are you running any other site, that might use the same domain you are using on the multisite?

Found the log, yes your way was much easier! local-by-flywheel.log (265.4 KB)

I’m not sure I understand your question? My multisite is named: Bizolly.local and each sub domain is named:


and so on.

Using health check plugin again is new info:

|PHP Version|7.1.4 - For best performance we recommend using PHP 7.2 or higher.| | — | — |

|Database Server version|5.5.60-0+deb8u1

  • For performance and security reasons, we strongly recommend running MySQL version 5.6 or higher.|

|PHP Extensions|* The optional module, libsodium, is not installer, or has been disabled.|