The Whole Thing is Broken

I gotta say, I am thoroughly disappointed in Local right now. When I first downloaded Local 6 months ago to improve my workflow from XAMPP, everything worked as expected. But now?? I can’t get anything to work as expected.

I’m building a multi-site for a friend and developing a custom plugin that will add user meta, create new users with an automatic username and add the user meta, and eventually some sales tracking via WooCommerce.

When I choose the Apache server, I get a 404 page for everything outside of the Dashboard. Switch to Nginx, and it’s giving weird errors that shouldn’t exist. e.g. Undefined values that ARE defined in if-else statements when creating a new user with front end form. I’ve tried all the different versions of PHP, both of the MySQL versions, switching back and forth, creating a new multi-site, and even tried a single site in Apache. (I didn’t even bother with nginx as I’m beyond frustrated…)

At the very LEAST Apache used to work with ZERO 404 errors when viewing the site. Now this is a worthless program for me I’m sorry to say.

Any way I can get some guidance or help with this before I switch back to XAMPP???

Multisites can be tricky to work on in any dev environment.

You mention 404 errors – is this multisite a subdomain or subdirectory one?

If it is subdomain, then you’ll need to periodically sync any new subsite domain to your hosts file so that the browser can correctly resolve the domain:

Also, is the 404 a generic apache error page, or is it a Local branded one? Reply with a screenshot of the browser so that we can get a little more context.

Hi Ben,

This is what I get. This is the sample page that comes with a default WP fresh install. I can view the home page, which is currently set to the latest posts, but that’s it.

It looks like multi-test is a subdomain off of fundpup.local which likely means that it is a new subsite – is that correct?

When creating a new subsite in a subdomain WordPress multisite, you’ll need to ensure that the new domain is added to the computer’s hosts file.

Local should be able to do that after creating the new site by clicking the Sync Multi-Site Domains to Hosts File link.

First thing to check is if doing the above fixes things. Here’s that workflow on my machine:

Now, the image you shared doesn’t seem like the error message I would expect from Local, so it’s possible that another offline development environment is giving that error. If you do still have issues after syncing the domains to the hosts file, I’d recommend zeroing in on what exact process is listening on port 80 and is responding to the browser’s requests.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.