How to connect to database using Sequel Pro, Sequel Ace or MySQL Workbench

The tutorial here seems outdated: How can I connect a tool such as MySQL Workbench to my Local site's database? - FAQ - Local Community

I do not have any remote host option:

How can I connect any of the mentioned SQL management programs mentioned in the title? Another user seem to have asked the same thing but no response: Need to update FAQ instructions for connecting to MySQL Workbench - Support - Local Community

I’ve tried connecting using the details shown but I always get a connection error

Can anyone help here? I still can’t get this to connect

I’m having the same problem. I’m running on MacOS 10.15.7 ( Catalina ) and trying to connect with :

  1. Sequel Pro
  2. Sequel Ace
  3. MySqlWorkbench

None of them allow me to use the socket displayed by Local.

None of them allow me to connect via or localhost on the port opened for the local site.

Sequel Pro returns this message for attempted connection via socket

Unable to connect via the socket, or the request timed out.

Double-check that the socket path is correct and that you have the necessary privileges, and that the server is running.

MySQL said: Can’t connect to local MySQL server through socket ‘/Users/malcolm/Library/Application Support/Local/run/C6tRgHFBp/mysql/mysqld.sock’ (1)

Sequel Pro returns this message for attempts to connect on localhost

To MySQL, ‘localhost’ is a special host and means that a socket connection should be used.

Did you mean to use a socket connection, or to connect to the local machine via a port? If you meant to connect via a port, ‘’ should be used instead of ‘localhost’.

Sequel Pro returns this message for attempts to connect on

Unable to connect to host, or the request timed out.

Be sure that the address is correct and that you have the necessary privileges, or try increasing the connection timeout (currently 10 seconds).

MySQL said: Lost connection to MySQL server at ‘waiting for initial communication packet’, system error: 60

Bump, I have the same problem as budasy. I am using MacOS 11 and attempting to connect with Sequel Ace.

As a crummy workaround one thing I did (that works!) is to edit the conf/mysql/my.conf.hbs file and replace socket = {socket}} with socket = /Users/MYUSER/Library/Containers/com.sequel-ace.sequel-ace/Data/mysql-wptest.sock. I also had to update the conf/php/php.ini.hbs wherever I saw {{mysql.socket}} I replaced with /Users/MYUSER/Library/Containers/com.sequel-ace.sequel-ace/Data/mysql-wptest.sock

And then in Sequel Ace I just specify the same path for my socket. Works. Mostly. The wordpress site works and also my Sequel Ace connects. The annoying thing that I have noticed is that when I shut down the site there is an error saying that it cannot dump the mysql database. Not sure if it matters though - I am brand new to Local, so can’t tell yet.

I tried that work-around too. As you say, it works sufficiently well to allow Sequel Ace to connect but it generates other problems. I’m still hoping for a fix that works.

Has the Local team not seen this issue or experienced?

1 Like

Would love to see Sequel Ace support instead of Sequel Pro as SP has not been updated in 3+ years and no longer works on Apple M1 chips.

Local on Windows uses ports to connect to the database, whereas Linux and Mac use unix sockets for performance reasons.

If you are on one of those *nix systems and want to connect to the DB over a port, you can follow the steps in this FAQ:

You’re right that Sequel Pro has been discontinued. We are planning on removing that from Local, but haven’t had a chance to get to it yet.

In terms of getting a connection to Sequel Ace, someone tried to create a Local add-on to help with that setup but ran into an issue in that the Sequel Ace team doesn’t support connecting over sockets:

Why not just install with Homebrew instead of from the App Store?

The only Sequel Ace add-on for Local isn’t official, and you have to build it yourself. I have no idea if it works.

Does anyone have a compiled, working Sequel Ace Add-on for Local?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.