I an getting error 504 request timed out

Issue Summary

When i first installed localwp, it was running fine. but since yester day this is the messsage i have been getting " 504

Request Timed Out

The page you requested generated a server timeout and could not be processed.
If you continue to get this message after refreshing, try restarting the Local site.

If the error persists, check the Local Router Logs in Local by going to
Help » Reveal Local Router’s Logs.
One or two sentence summary of the issue.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?
    v 6.1.1
  • What Operating System (OS) and OS version is being used?
    • For example: macOS Catalina or Windows 10 Professional
      windows 10 professional
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @ericstephen

A lot of things can cause a 504, to start you might simply try restarting Local, or restarting your machine. If you’re running any other large programs and Local at the same time you might try closing those down.

We have some other tips here that might help resolve your issue: Troubleshooting Performance issues in Local - Local

If you’re still having trouble, shoot us over your Local Log and we can take a deeper look: Retrieving Local’s Log File

local-lightning.log (1005.3 KB)
I think I have tried most the things you suggested. I have uploaded my local logs to this reply for your perusal and hopefully come up with a suggestion that can help me resolve it.

Hi @ericstephen

Do you have any antivirus, security, or firewall applications that could be blocking Local? It looks like from the log it might be having trouble connecting.

More details about troubleshooting this here: Router Mode

Thank you, Nick, but I have tried my possible best to try to find a solution to this problem. I read the troubleshooting in router mode but still no headway. I even tried to fetch out what is listening to port 80. But for some reason, I can’t find port 80 on my command prompt. A screenshot of the command prompt is attached


Nick-B WP Engine Team
March 18


  • | - |

Hi @ericstephen

Do you have any antivirus, security, or firewall applications that could be blocking Local? It looks like from the log it might be having trouble connecting.

More details about troubleshooting this here: Router Mode

Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.


To back up here a little bit, do you get the 504 errors just when you’re using Local with any site? Or is it only a specific site? For example, if you create a new, blank site in Local do you still get errors?

Ok…I haven’t tried it with any site. Just one site. I will create another site and revert to you.

Sounds great @ericstephen keep us posted :green_heart:

Hello Nick. I have tried to create another WordPress website, the picture below is what I got.

After disabling my antivirus, the new site created is giving me error 404 not found while the old site is still giving me error 504 request timed out.

When the hosts file is unable to be updated that usually indicates something is still blocking Local. Are you running any other developer applications simultaneously?

But it was working before. I downloaded it like a week and used it consistently for that week before I started facing this challenges of errors. I have not downloaded anything on my system. In fact localwp was the last application I installed on my PC.
If an application is disturbing it from running I should have been faced with the problem from day one that I installed it. Don’t you think?

You’re right that is strange. I’m not in disagreement with you there, just trying to rule out common offenders here.

Are you still working with Local 6.1?

In order to refresh here and start with a clean slate could you give the below troubleshooting steps a try?

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!

Is there where I can go and possibly stop running applications so that I can limit diagnosis

This might help you:

Thank you very much Nick for the help so far rendered. Below is an update of my journey.
On the error 504 issue, I have tried all what you asked me to try out. The error 504 was not resolved. However you told me to install the updated version of localwp which I did. You also told me it was pertinent to export my website in a folder in another section of my laptop. I tried to export the website from localwp to a separate file, but i got an error message in doing that.
Nevertheless I uninstalled the version I had and installed the newer version. after the installation of the new version the error 504 disappeared. but right now the error message i am getting from my home page when I click visit my site is (" This page doesn’t seem to exist.
It looks like the link pointing here was faulty. Maybe try searching?"). but the thing is if I go to my pages on WordPress and click home page I don’t get that error message. I don’t know why I am getting that kind of message when I click on visit my site on WordPress?

Hi @ericstephen

You may need to try clearing the cache and cookies on your browser and then closing your active sessions to start with a clean slate.

How do I clear my browser’s cache?

You may also try utilizing a different browser (Firefox, Safari, Internet Explorer if you’re using Chrome for example) or an Incognito window to troubleshoot further.

The easiest way to open an Incognito window is with the keyboard shortcut combination Ctrl-Shift-N (Windows) or Command-Shift-N (macOS). Another way is to click on the menu on the upper right — it’s three vertical dots — and select New Incognito Window from the list.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.