I cannot add featured image of post.Wordpress shows “MISSING TEMPORARY FOLDER” massage. I am using LOCAL 6.4

Issue Summary

One or two sentence summary of the issue.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

1 Like


Windows 10 21H2
The same thing happened to me. Local 6.4.0+5927
Apache, PHP 7.4.1, MySQL 5.728
WordPress 6.0
Tried to install Woocommerce - Plugin fails to install
So I tried to install it by uploading the plugin - I get a 500 document error
Tracked down the error in the logs

FcgidMaxRequestLen 20000000 to apache2.conf.hbs
Then I got the “Missing a temporary folder.”
Following How to Fix "Missing a Temporary Folder" Error in WordPress
I added a temporary folder
Still getting the “Missing a temporary folder.”
Error message in the log is
{“thread”:“main”,“class”:“Process”,“process”:“httpd”,“level”:“warn”,“message”:“AH00558: httpd.exe: Could not reliably determine the server’s fully qualified domain name, using fe80::9990:788:e08f:7aad. Set the ‘ServerName’ directive globally to suppress this message”,“timestamp”:“2022-06-14T11:23:40.664Z”}

Added ServerName localhost to apache2.conf.hbs

Still getting the “Missing a temporary folder.” when I upload the Woocommerce plugin.

Now I’m stuck.

Interestingly - WP updated some theme translations without any problem.

Able to install Woocommerce without errors on nginx, PHP 7.4.12, MySQL 8.0.16; the default settings.

Hello there! This may be due to a recent bug that has surfaced. More details and information to follow here: Unable to upload media files on Windows when using Apache

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.