Import hangs at "Extracting files" [Windows]

I can create new sites from scratch and from blueprints, but importing does not work. It gets to “extracting files” and then never finishes. I’ve given it up to an hour and it never finishes. If I interrupt it and then click on the new site’s name in the left menu, it flashes briefly then Local crashes.

Note: I am hosting with Flywheel and using backups downloaded from my Flywheel account.

Local 2.0.1 on Windows 10

1 Like

I just wanted to follow-up to say that I’ve upgraded to 2.0.4 and imports still stick at “Extracting import”.

Here’s a screen shot of an import that has been running for about an hour now…

Sorry, haven’t got a solution, but I get exactly the same error when importing. Seems to be a conflict with file rights in the OS, for me that is Windows. Tried running it as Administrator as well, same problem.

This is the error in the log:
Jun 12, 2017, 8:26 PM GMT+2 - warn: [main/index] Unhandled Rejection at: Promise { state: ‘rejected’,
{ Error: EPERM: operation not permitted, rename ‘C:\Users\user\AppData\Local\Temp\local-by-flywheel-B1eFH28nMZ’ -> 'C:\Users\user\Local Sites\lidtsmartere-dk-2017-may-31\app\public’
errno: -4048,
code: ‘EPERM’,
syscall: ‘rename’,
path: ‘C:\Users\user\AppData\Local\Temp\local-by-flywheel-B1eFH28nMZ’,
dest: ‘C:\Users\user\Local Sites\lidtsmartere-dk-2017-may-31\app\public’ } } reason: Error: EPERM: operation not permitted, rename ‘C:\Users\user\AppData\Local\Temp\local-by-flywheel-B1eFH28nMZ’ -> 'C:\Users\user\Local Sites\lidtsmartere-dk-2017-may-31\app\public’
Jun 12, 2017, 9:15 PM GMT+2 - info: [main/index] before-quit:
{ B1wMvkJeW: ‘halted’,
BJVy5VcRe: ‘halted’,
‘S1j_ToAW-’: ‘halted’,
HyKBnInzW: ‘adding’ }

1 Like

I’m trying to reproduce this right now on Windows.

Sorry for the trouble!

Good news! I was able to reproduce it :slight_smile:

I’ve filed an issue and I’ll work on a solution ASAP.

Thanks Clay. I’m happy that you found it but sad at the same time. :wink:

1 Like

Just created and tested a fix. It will be available in the next update of Local for Windows.

Has the update been released yet? I’m also having this problem :slight_smile:

I’ve had this problem as well, but slightly different – “Error: EXDEV: cross-device link not permitted” with renaming the source file on one drive to the target file on a second drive where I’m trying to install my site. Just thought I would mention it to make sure your fix covered working with two different logical volumes :slight_smile:

Look forward to the fix so I can get to work on my site!

1 Like

Thanks for the heads up! I’ll make a note to test that as well.