Local Community

Import Site

I want to import a website as a local site into Local.

I have downloaded all the files from the webspace.

Then downloaded the database via phpMyAdmin in the customer login as well.

The site is called asp-hamburg.de.

The folder with the WP files is called asp-hamburg, the database kept the naming from the export, where the database name also appears.

From the files of the webspace and the database I created a ZIP archive.

I cannot import the website and database into Local and create a local website.

I keep getting an error message just before the import completes when the database is installed:

Error: Command failed: /Applications/Local.app/Contents/Resources/extraResources/lightning-services/mysql-8.0.16+6/bin/darwin/bin/mysql local -B --disable-column-names -e SELECT option_value FROM wp_options WHERE option_name = ‘siteurl’;
ERROR 1146 (42S02) at line 1: Table ‘local.wp_options’ does not exist

How can I create the local website?

Hello there, Thomas! Welcome to the Local Community! :wave:

That error message is indicating that Local is trying to pull the site’s url from the local.wp_options table (which stores that information) but for some reason that doesn’t exist.

We will want to work out why that table is missing. Here are a few things to look into:

  • If you inspect the sql file that contains the backup, does it have the necessary SQL to create the wp_options table?

  • How was the site’s backup created?

  • Are there additional SQL files within the site backup? Sometimes when those are imported, they can mess with the import process

Lets start there!

:woman_technologist:t3: Sam

Hello, Sam.

let’s take a different approach to setting up the local site.

I have the content of the web space of the site in a folder. And the database that goes with it.

How do I set up the local site without error message and successfully?

Hi there @Thobie!

Have you looked at this thread, by chance?

It sounds like maybe the name of the database being the same as the site asp-hamburg could be causing issues. Is that something you can change when exporting or rename?

Let me know if this helps!

Sam

Hello,

I was able to solve the problem. I did it manually.
First created a new empty wordpress site.
Then replaced the content of the site with the content of the webspace of my existing site.
Then I customized the wp-config.php file with root/local/localhost.
And in a new “sql” folder copied the database of my site.
So I could access phpmyadmin in Local. In it I imported the content of my database. Then I deleted the content of the local database and copied the content of my database into the local database.
Now I was able to start the site locally via Local and dial into the backend of my site locally.
Everything works now.
Regards from Hamburg

Thobie

1 Like

Hello there @Thobie :wave: -

I am so happy to hear it all worked out, thank you for explaining the steps you took!

Please reach back out if you have any more questions in the future,

Sam :woman_technologist:t3:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.