Local Community

Initial error msg: ERR_TOO_MANY_REDIRECTS

  1. Cleared cookies and cleared cache. Problem was not resolved.
  2. Later on, I was trying to Change my Site Domain, when I got an error which read- Warning! The site’s Wordpress URL settings do not match the host set in Local. Now website is inaccessible. Continuously Provisioning.

Please help.

It’s hard to say what exactly is going on without more info.

Can you try installing the latest version of Local and see if that fixes things?

If you still have issues, the latest version of Local, has a “Download Local Log” button on the “Support” tab. Can you upload the file that Local creates after clicking that button?

In addition to that log, can you let us know if this is happening for only one site in particular, or for all sites, even newly created, plain WordPress sites?

local-logs.zip (15.4 KB)

This problem was only evident on only one site (the original site to be created on my WordPress account).

Thank you very much for your prompt response.

Did you recently work with SSL on the site? For example, enable SSL or possibly change the certificate?

I’m seeing a few errors within the Router Log that appear to be related to NGINX not being able to make a secure connection:

2021/11/23 00:28:27 [crit] 16940#4388: *7 SSL_write() failed (10053: An established connection was aborted by the software in your host machine) while sending to client, client: 127.0.0.1, server: moleli-high-school.local, request: "GET / HTTP/1.1", upstream: "http://127.0.0.1:10004/", host: "moleli-high-school.local", referrer: "https://moleli-high-school.local/"

You might be able to do a search and replace on the database and change the site back to using regular HTTP. That process is most easily done with wpcli within a terminal. Right-click on the site in Local and select “Open Site Shell”. From there, you should be able to do a search and replace with this command (being sure to double check that the domain is the correct one for your site!) Also note that the only difference between those two domains is that one has the 's' in https:

wp search-replace 'https://example.local' 'http://example.local'

Let us know how it goes!

I didn’t work with SSL per se, but changed the Domain Name on the Local Site - Overview page. Soon afterwards, started getting an error which read- Warning! The site’s WordPress URL settings do not match the host set in Local. Then website became inaccessible. Continuously Provisioning.

After following your above instructions on searching and replacing the domain http with https, i got a message in CLI - “Success: Made 0 Replacements.” The page is still not reachable.

However, the local website address is showing up in the address area of the browser as follows - (http://website-name.local.local/).