What issue or error are you experiencing?

When connecting to the Wordpress website I get the browser error: SSL_ERROR_RX_RECORD_TOO_LONG’

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

I imported an export made by WP Migrate DB. When it was finished an error message was on top of the Local app that (I think) said there was an error with the connection. To the right of this message was a button that said to change to localhost (can not recall exactly). So I did.
Next I connected to the website, but got this error message. Not when connecting to WP admin.
I connect to https://localhost:10004/

System Details

  • Local Version:
    Version 8.1.0+6514
  • Operating System (OS) and OS version:
    Mac OS Sonoma 14.1.1

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-lightning-verbose.log (49.1 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @kromm

If you go back to Site Domains Router Mode is your Local App SSL trusted?

Do you get the same results in different browsers?

We have some more SSL troubleshooting steps here:

Hi Nick-B, thx for your reply.
Yes in Router Mode the certificate is trusted.
Firefox, Chrome, Safari and Tor browser all give the same result. I read some documents and tried a couple of things, but didn’t find a solution. I could try and create a localhost certificate, but I don’t want to go into that. I hoped for a quick install but it takes too much time. Thx anyway.

Hi @kromm - No problem! Always happy to help if you have other questions or issues.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.