Installation failed in ubuntu 24.04 lts

in ubuntu 24.04 lts i try install local-9.0.1-linux.deb and when i try to install with dkpg its installed but app not open at all and when try install with apt i see this error:
The following packages have unmet dependencies:
local : Depends: libaio1 but it is not installable
Depends: libncurses5 but it is not installable
E: Unable to correct problems, you have held broken packages.

Hi @mmansouri86

The information in this thread should be helpful:

@mmansouri86 There is something you can do, this is what worked for me:

First, you need to manually download the libtinfo5_6.4-2_amd64 that is a dependency for the libncurses5 package.

You can download it using curl to:

curl -O http://launchpadlibrarian.net/648013231/libtinfo5_6.4-2_amd64.deb

install it with dpkg:

sudo dpkg -i libtinfo5_6.4-2_amd64.deb

then, download manually the libncurses5_6.4-2_amd64.deb deb package. Can do it with curl too:

curl -O http://launchpadlibrarian.net/648013227/libncurses5_6.4-2_amd64.deb

then install it with dpkg:

sudo dpkg -i libtinfo5_6.4-2_amd64.deb

Lastly, download the libaio1 deb package.

curl -O http://launchpadlibrarian.net/646633572/libaio1_0.3.113-4_amd64.deb

and install it:

sudo dpkg -i libaio1_0.3.113-4_amd64.deb 

After this, the warnings about dependencies should disappear.

1 Like

not work in 24.04 lts

i install libtinfo5_6.4-2_amd64.deb, libtinfo5_6.4-2_amd64.deb and libaio1_0.3.113-4_amd64.deb and now when i try to install local i see this error and dependency:
dpkg: dependency problems prevent configuration of local:
local depends on libncurses5; however:
Package libncurses5 is not installed.
local depends on libnss3-tools; however:
Package libnss3-tools is not installed.

dpkg: error processing package local (–install):
dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.17-2) …
Processing triggers for gnome-menus (3.36.0-1.1ubuntu3) …
Processing triggers for desktop-file-utils (0.27-2build1) …
Errors were encountered while processing:
local

There was an error in my comment, in the libncurses5 installation step. In my comment, libncurses5 was downloaded but the instructions say to install libtinfo.

You have to do this instead.

download the libtinfo5_6.4-2_amd64

curl -O http://launchpadlibrarian.net/648013227/libncurses5_6.4-2_amd64.deb

then install it with dpkg:

sudo dpkg -i libncurses5_6.4-2_amd64.deb

To fix the problem with libnss3-tools, just install it with apt:

sudo apt install libnss3-tools 

This is what worked for me.

Thank you for sharing those details @aldrick!