Local under Ubuntu 24.04 - libssl.so.1.1 missing

After encountering the issues of missing libraries during installation of Local and fixing that by following these instructions I am unable to create a site. The error goes on about missing libssl.so.1.1. Trying to fix this issue using the instructions here does not help, because that version is not available at all on my system.

Screenshot from 2024-05-09 16-15-59

The available libss.so files are these:

❯ ln -s /usr/lib/x86_64-linux-gnu/libssl
libssl3.so   libssl.so.3  


  • Ubuntu 24.04 clean new installation with all update and build tools
  • Local 9.0.2

From the screenshot, it looks like this site was using PHP 7.3.5. I tried creating a new site on my Ubuntu 24.04 box and ran into the same error as you, but PHP 7.4 and up seem to work. Can you try a newer version of PHP?

PHP 7.3 has been EOL for a couple of years now:

And we haven’t done anything to re-compile it with different libs.

I suppose if you really need to use 7.3, you could try installing an older version of Ubuntu, install Local and use 7.3, but you’re probably better off trying a newer version of PHP.


You can download the package manually from the Ubuntu packages and install too.

Do it using Curl:

curl -O http://security.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.1_1.1.1f-1ubuntu2.22_amd64.deb

and then use dpkg to install it:

sudo dpkg -i libssl1.1_1.1.1f-1ubuntu2.22_amd64.deb

This was necessary for me, to create sites using PHP 7.3.5 on Ubuntu 24.04. Hope this works for you.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.