Local Community

Installed new update and my site is gone

Issue Summary

Installed new update and my site is gone
Open site opens http://wp1.local/ with 502 # Request Error

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    I had one
  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Yes

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?
    Now it’s 6.6.0 + 6231

  • What Operating System (OS) and OS version is being used?
    Win10 Pro

  • Attach the Local Log.
    local-logs.zip (9.6 KB)

Hi @LMRig

Is the site no longer in your Local app at all? Or it’s showing in your Local app but it just won’t open and gives you a 502 error?

If it’s not showing in the app at all, you should be able to track down your Local Sites folder on your machine and re-import the site back into the app. It’s possible an update may have shifted some files or directories somewhere.

It’s still in app but button to open the site opens error local site like there are no files for this site.

Hi @LMRig

The error in your logs indicates that Local can’t find that file/folder for some reason. Are you able to locate the actual site folder or files in your machine by searching to see if they shifted in path or to another drive?

Does the program move important folders and then throw errors?
If so, you should know if it does and where?

I don’t know what folder name to look for.