Local Community

Internal Server Error - Apache

Issue Summary

Imported sites where the web server is set to Apache fail with “Internal Server Error” either 500 or 502. Oddly if I switch to nginx then they work. Since my actual hosts are Apache i would like to mimic the setups even if that’s not necessarily going to impact the WordPress site particularly.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

I imported 2 sites and tried to mirror their setups (PHP, mySQL and Apache) to match. Both failed with Internal Server Error. But if switched to nginx web server then they do work. (sitenames “namgbr-old” and "namgbr-a2).

A fresh/new install with an Apache webserver works OK (sitename “test”)

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

Yes - as noted that works.

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

Not sure - probably unqiue to my setup.

System Details

  • Which version of Local is being used?
    6.6.1+6281"

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
      |Edition|Windows 11 Pro|
      |Version|22H2|
      |Installed on|‎10/‎19/‎2022|
      |OS build|22621.1265|
      |Experience|Windows Feature Experience Pack 1000.22638.1000.0|

Windows 11 Pro “osPlatform”:“win32”,“osRelease”:“10.0.22621”,“osArch”:“ia32”,“windowsEdition”:"Microsoft Windows 11

  • Attach the Local Log. See this Help Doc for instructions on how to do so:
    • Retrieving Local’s Log
      Mote that the errors in the router logs are NOT for the current problem sites. I tried uninstalling Local and reinstalling it and when importing the 2 sites again gave them different names e.g. (sitenames “namgbr-old” and "namgbr-a2). So it seems after a reinstall I am not getting router log errors now.

I think it’s something to do with the httpd.exe Windows firewall settings. It’s allowed for private networks and just in case I enabled for public networks also not change. I’m on a private network setting in Windows currently.

I see this happened before but there wasm’t a specific answer. I have not yet tried exporting from Local and re-importing as was suggested as it was not it didn’t work. I may try it anyway.

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.
local-logs3.zip (4.4 KB)

I did try to export the site to ZIP and then re-import. Makes no difference - Internal Server Error.

But even with the Export and Import site flipping the webserver to nginx allows the site to work. Weird.

Hi @esd3104

You might find this post below helpful, feel free to upvote and comment since it’s a feature request! We use these to priorize issues and roll out future enhancements!