Issue with Redirection to wp-signup on Multisite Network

What issue or error are you experiencing?

Hello Local Community,

I recently started using Local for a WordPress multisite network and encountered a consistent redirection issue.

Whenever I access the wp-admin dashboard of a newly created subsite (e.g., sub-site.site.local/wp-admin) or even the main site, I am immediately redirected to the main site’s wp-signup page (site.local/wp-signup). Interestingly, appending a trailing slash to the URL (e.g., site.local/wp-admin/) resolves the issue, the issue only happens when I’m not logged in.

Steps I’ve tried to resolve the issue include:

  • Creating a new project without any plugins, which resulted in the same redirection behavior.
  • Implementing a mu-plugin to override the redirection without success.
  • Switching the server from Nginx to Apache and modifying rewrite rules in the .htaccess file, but the problem persisted.

Could you please assist me in resolving this redirection issue? Thank you for your help!

Best regards,


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

  1. Create a New WordPress Multisite Project:
  • Set up a new WordPress project in Local, enabling the multisite feature with subdomains.
  1. Access the Admin Dashboard:
  • Open a private browsing window.
  • Navigate to the URL yourdomain.local/wp-admin without including a trailing slash at the end.

System Details

  • Local Version:
    Version 9.0.2+6676
  • Operating System (OS) and OS version:
    Windows 11

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
There was no errors that popped off.

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @oumouchaibo

I did some testing with this, and I can replicate the issue with the steps you provided, i.e., I use an incognito window to access the specific admin URL without a trailing slash. That being said I may need some clarification on where this is impeding your workflow. When I create a test multisite with subdomains I have no problems accessing the WP Admin or dashboard for either of these. How are you generating the redirect in your workflow or testing that is causing an issue?

Hi @Nick-B,

Thanks for your response—I really appreciate it. Here’s a video showing my exact setup:

When I create a registration page and enable it, users can’t access the admin login without including the trailing slash, or they need to go directly to “wp-login” instead of “wp-admin.” I’m also open to simply changing the redirection so it directs users to “/wp-login” of the same site or sub-site, rather than redirecting to the “/wp-signup” page of the main site.

As shown in the video, accessing “justanother.testing.local/wp-admin” results in a redirection to “testing.local/wp-signup.”

Hi @oumouchaibo

So does the behavior persist when the site is hosted and live? Or is it only within your Local app?

Your Local multisite will never be accessible to other users until it’s actually migrated out of Local and moved to your own server or hosting solution. That’s why I’m a little confused about how this is impeding your development of the site.

@Nick-B,

No, the website isn’t live yet, and I’m worried that the issue will continue when it does go live. I’m trying to resolve it before starting the development and setup. Did you push it live to check if the error still happens? Sadly, I can’t test it myself since I don’t have a hosting site yet.

When I posted this question, I considered that I might have made an error during environment setup, which could be causing the problem. Others might not encounter the same issue.

Moving multisites out of Local is a bit more of a manual effort. I haven’t tested this myself in some time but we do have lots of users that utilize multisite and haven’t heard of this being a consistent issue after moving a site out of the app. Local Connect does not support multisites so the best way is to use a migration method. We have some recommendations here depending on who you host with:

1 Like

@Nick-B Thank you! I am just happy that I haven’t done smthg wrong with the configuration I will now just start the development and as you said if no one has ever faced this problem in live this is a good sign!

Thanks again @Nick-B, that was a huge help!

1 Like

No problem @oumouchaibo! If you have any other questions or concerns don’t hesitate to reach back out. We are always happy to help!

1 Like

@Nick-B I think I found the main reason why this is happening, when going to wp-admin with no trailing slash the requested site get’s added a port number and treated like it doesn’t exist so it redirects to register to add the site.

Do you have any idea how to prevent adding :port to the url ?

here is an example:

http://justanother.testing.local/wp-admin redirects to http://testing.local/wp-signup.php?new=justanother:10016 “You can see the port number there”!

Hey @Nick-B I think I found a solution!

so this happens only when nginx configuration is trying to add a trailing slash to the wp-admin, what you can do is:

  1. go to conf\nginx
  2. open the site.conf.hbs file
  3. add port_in_redirect off; under root “{{root}}”;

And You fixed it! Mark this as a solution if that worked for you so others can find it too! :grin:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Thank you for sharing that for others to find @oumouchaibo!