Local Community

Lightning Public Beta issues with MySQL

The following formerly worked in Local Lightning beta3 but now errs in 5.0.4.

touch /tmp/my.cnf
printf "[client]\npassword=root\nuser=root" >"/tmp/my.cnf"
SOCKET=$(mysqld --verbose --help | grep ^socket | awk '{print $2, $3, $4}')
PORT=$(mysqld --verbose --help | grep ^port | head -1 | awk '{print $2}')
mysqladmin --defaults-file="/tmp/my.cnf" create "wordpress_test" --host="localhost" --port="$PORT" --socket="$SOCKET"


mysqladmin: connect to server at ‘localhost’ failed

error: 'Can’t connect to local MySQL server through socket ‘/Users/afragen/Library/Application Support/Local/run/PGDT9sMcd/mysqld.sock ’ (2)’

Check that mysqld is running and that the socket: '/Users/afragen/Library/Application Support/Local/run/PGDT9sMcd/mysqld.sock ’ exists!

Socket does exist.

$ ls -la “/Users/afragen/Library/Application Support/Local/run/PGDT9sMcd/”
total 24
drwxr-xr-x+ 9 afragen staff 288 Sep 11 12:32 .
drwxr-xr-x+ 12 afragen staff 384 Sep 11 11:27 …
-rw-r–r--@ 1 afragen staff 6148 Sep 11 11:39 .DS_Store
drwxr-xr-x+ 5 afragen staff 160 Sep 11 11:27 conf
drwxr-x—+ 34 afragen staff 1088 Sep 11 12:34 mysql-raw-data
srwxrwxrwx+ 1 afragen staff 0 Sep 11 12:32 mysqld.sock
-rw-------+ 1 afragen staff 6 Sep 11 12:32 mysqld.sock.lock
drwxr-xr-x+ 9 afragen staff 288 Sep 11 11:27 nginx
srw-rw----+ 1 afragen staff 0 Sep 11 12:32 php-fpm.sock

I have no idea why mysqladmin cannot connect via localhost either.

I could really use some help as this all worked in 5.0.3 and now not in 5.0.4

Yes, this is all in the site shell.

OK, the solution seems to be that using all the variables in the mysqladmin command is both unnecessary and causes problems in beta 4.

Simply using mysqladmin create "wordpress_test" is sufficient and works.

Awesome, glad you sorted it. You had me worried for a bit :smiley:

I was worried for a bit too. :smirk:

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.