Live Link Redirects to "It Works!" default server page

When I turn on live link, my live link url loads the “It Works!” default server page instead redirecting to my local site. This happens with sites with a site url using https and sites with a site url using http. Any ideas?

Issue is still not resolved. Any one else experiencing this?


Please go to Preferences » Advanced and enable the IPv6 Loopback option.

I had IPv6 Loopback enabled. When I disabled it, the live links routed correctly. Thanks!

Whoops! Sorry for confusing the two :sweat_smile:

Glad you got it sorted :slight_smile: