Live Links not showing the site correctly

Hi, I have 3 websites that I have designed in Local. I finished my first site for a client yesterday, and can not get it to appear correctly in Live Links. I have tried everything I can think of and can find online.
The site appears in the live link. The header comes across all jumbled around. Clicking on the menu that is not where it’s supposed to be does nothing, but the site logo is there. The header and footer have a bunch of giant plus and minus signs.
The hero just below the header and just above the footer is not present, but the text and buttons are there. Everything else looks to be correct on the home page.
Does anyone have any ideas or another simple way to share this site with my client? Any help would be appreciated. I have also tried using live links with the other 2 sites that I have in the system and they perform the same way.
Thank you

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:

  • Operating System (OS) and OS version:

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @davekoupal!

Live Links don’t match your Local Site URL (ie: mysite.local), so Local attempts to rewrite these on the fly. Live Links is broadly compatible with many themes, plugins, and custom code snippets. However, some images, front-end assets, or other HTML elements may be missing from your site when viewing it over Live Links.

As a first step you can try running a search and replace command to help clean up any mixed content type errors. To do this you can simply click on Open Site Shell in your Local app under your site name. The command would look something like this:

wp search-replace 'SITEURL' 'LOCALURL' --skip-columns=guid

As a tip you would:

You’ll also want to make sure you Trust Local’s SSL certificate, to help avoid insecure content as well.

If you’re still noticing issues, check to see if you have plugins or themes that retain caching or have a “Regenerate CSS” option. These may need to be refreshed in order for changes to be displayed.

There may be other plugins getting in the way as well if they are trying to force SSL/HTTPS.

If you’re still having issues you might open up the console of the page and see what errors are present. Is it still showing some mixed content or some other type of issue?

You might try viewing it in an incognito window, a different browser, or over LTE Data instead of WiFi to see if caching is getting in the way as well.

As another workaround, if you’re still having trouble, you could try pushing the site up to a Demo to see how it looks there. Flywheel offers free 14 day Demos that you could test out: Demo Site

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.