Local Could not update hosts file

Local can’t update my hots file, every time I try I get this error message:

I already tried to turn UAC on as suggested here: Permissions Issues with etc/hosts

I also checked that I don’t have any program assosiated to the .bat extension as that was causing problems here: Missing Hosts Entry. User did not grant permission. Windows 10

I don’t have any antivirus other than Windows Defender, but even if I turn that off the error is still there.

Even running the app as administrator didn’t fix the issue.

I already checked the permissions on the hosts file, the checkbox on “Only read” is not ticked.

This is my log file: https://pastebin.com/QDTKQkeU

My desktop pc where Local is not working properly: Windows 10 Pro 18362.900
My laptop where Local is working fine has Windows 10 Home 18362.863

I think I checked EVERY topic on this community talking about this issue but I haven’t found the solution yet.


Hello… stil no replies, someone know how to solve this issue? @clay

1 Like

It probably won’t help you much, but I just wanted to let you know that I had the very same error message when importing a Local site on a Windows 10 32Bit virtual machine (Parallels). Despite allowing execute.bat to make changes.

So I google and found your message here. As you described several ways that did not help, I just deleted the site and tried again.

Again I allowed execute.bat to make changes. This time it worked. The message “Changing site domain …” stayed on the screen for quite a while and I was expecting it to fail again, but it didn’t.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.