.local extension changed

Issue Summary


At some point the file extensions for my sites changed from sitename.local to localhost:portnumber. The main issue with this is that when I try to log into a wp-admin panel from the site URL I am redirected to localhost/wp-admin, which breaks the site.

This happens with all my sites on Local. Only started recently, likely within the last couple days. Doesn’t seem to coincide with any updates. I updated to the most recent version of Local which also didn’t fix anything.

I can create a new plain WordPress site in Local, but I can’t acccess the wp-admin panel.

MacOS Mohave 10.14.6, Local version 6.1.1+5468

Any help would be appreciated. Thanks!!

I just figured this out, kind of a silly mistake. I forgot that I had servers up and running on a MAMP install, which was occupying port:80, which is what Local uses to run the sitename.local router mode. This article: https://localwp.com/help-docs/advanced/router-mode/ was helpful in figuring it out. After you stop anything running on port 80 you can then force the router mode to change in Preferences > Advanced.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.