Port 10004 seems to be used for wp-admin access?

Issue Summary

After I have downloaded my site from WP Engine to Local app on a Mac Pro M2, if I go to https://mysite.local/wp-admin, the Chrome browser switches this to https://mysite.local:10004/wp-admin. If I edit out the :10004, Chrome then allows me to go to the site and it works fine.

This is more annoying than show-stopping, but I’ve seen that other users have reported similar problems, and I don’t see a published solution.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?


  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?



Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?


  • What Operating System (OS) and OS version is being used?
    • For example: macOS Catalina or Windows 10 Professional

Mac OS Ventura 13.4 (also failed on 13.3)

  • Attach the Local Log. See this Help Doc for instructions on how to do so:


Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the po

ssibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.
local-logs.zip (22.8 KB)

Hi @drgreening

If you go to Local > Settings > Advanced and change your Router Mode to Site Domains does that resolve the issue for you?

Already set to Site Domains

Okay got it, thank you

Have you made any changes to the domain name since getting the site into Local?

Are you running other developer applications? Like MAMP, XAMPP, or Docker for example.

If you create a new, blank site in Local does that admin behavior work the same way? Or is it only happening for one site?

Here’s all the open ports that attach to or from 443. You can see that the only application that has 443 as a destination is nginx (server for Local app).

This domain name was in use by another install (a download from WPEngine). I deleted that install (through your app) and re-downloaded the site from WPEngine.

lsof.log (12.6 KB)

I installed a new site on test, configured all the stuff through Keychain Access so test.local should work and, weirdly, when I tried going to “https://test.local/wp-admin” it redirected to (insecure) http://test.local/wp-admin/. When I typed the login/password, it logged me in and then redirected to https://test.local:10014/wp-admin. So that’s some kind of weird thing you guys do.

BUT when I typed https://test.local:443/wp-admin after logging in, that actually worked.

And then I looked at the Wordpress settings and you had Wordpress Address and Site Address both set to (insecure) http://test.local. I changed those to https://test.local.

NOW when I logout, and then try to login to https://test.local/wp-admin, it redirects to https://test.local:10014/wp-admin/ and gives me the screen attached.

So you guys are doing some kind of weird thing, possibly to compensate for folks having trouble configuring the OS, and opening new unique ports for HTTPS on each instance? I can a situation where you might need that, but it isn’t need here obviously: virtual hosting seems to work fine with 443… except that you, or someone, is redirecting 443 to 10004 for one of my sites, and to 10014 for this new test.local site.

Can you pass this discussion onto a developer to see what they say?


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.