LOCAL Installation broke FaceTime camera on MBPro

I recently installed Local By Flywheel in order to evaluate it for developing a WordPress based web-store. The installation seemed to go well and I was able to use the WordPress Dashboard to install WooCommerce and start to set up a web store.

However, when I later tried to use FaceTime on my MacBook Pro, it said that there was No Camera available. This had been working fine less than a week ago.

I found a number of online reports stating that VirtualBox installations may cause the FaceTime camera to stop working on MBPs, but the only solution they recommended was to uninstall VirtualBox.

Do you have any suggestions on how to fix the FaceTime camera issue, caused by VirtualBox ?

Have you considered using the Native App Docker for Mac, that uses HyperKit, instead of running Docker on top of VirtualBox ?

Any suggestions are appreciated.

Just checked, my FaceTime camera works without problems (Retina MBP 2012).

Do you see any FaceTime or Webcam-related errors in the Console?

Hopefully, since Parallels seems to have found a fix, there might soon be one available for VirtualBox as well.

I think there is work being done to have Local run on HyperKit (without Docker for Mac, for some reason).

– Spock out.

Hi Phil,

I tried that “replug_facetime” code yesterday, but it reported that it could not find the FaceTime camera.

I am using an older MBPro, so the problem might be the fact that it was identified as an “iSight camera”

in the “list of USB devices” If the code was available, then I could try editing it to search for the iSight

name as well.

I did verify that the iSight camera would work properly in FaceTime and PhotoBooth when I booted up

my MBPro into Safe Mode, which does not allow non-system Kext from loading. When I returned to

"Normal Boot”, the iSight camera is not available.

If I connect a Logitech USB camera to my MBPro, then I it works fine, but the iSight camera is still a no-go.

I am planning to do some experiments with Unloading the VirtualBox Kext files, one by one, to see which

one may be causing the problem. I will let you know if I find a specific culprit.

I don’t want to uninstall VBox and Local at this time. I am still trying to develop my new web store on

this platform.


Kirk Symons

Hi Phil,

I managed to fix my problem by using a Hex editor to change the text string “facetime” to " isight " in the replug_facetime utility, that was made by someone in the Parallels community.

I renamed my version of the utility to replug_iSight

I later found a copy of the code for replug_facetime and saved it for another day when it might be needed.



Do you have a copy of your replug_isight version? I am having the same problem. The replug_facetime file tries to find the Facetime camera, but my camera is listed as iSight camera.
I have no idea on how to edit that file so it can search for isight instead of facetime.


John D.

Hi John,

I have placed a copy of the replug_iSight utility into a shared folder on my web store.

You can download it from http://vericorder-outlet.com/private-xfers/replug_iSight.zip

The ZIP file contains the utility and a brief ReadMe.txt file that says how to use it.




Hi Kirk,
Thanks so much for sharing your copy of the file. Followed the steps mentioned on the txt file and worked with no problems. Finally got my camera working.



Hi John,

Glad I could help


Holy cow, this is interesting!

Thanks for sharing the information and drivers here.