Local Community

Local is Installing Old Wordpress Version

Issue Summary

I am a high school teacher attempting to use local to teach my students how to use WordPress. When install Local on my system, it works fine and I get a clean install of WordPress 5.9.1. However my students’ systems are launching WordPress 5.2.x. I cannot find any settings that are different between our installs. Additionally, our hardware specs are identical. The only difference in the install process is that I have to provide admin access for them to create a site.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    All WordPress sites installed on Student systems.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Yes, however it is very outdated and has issues accessing things like the theme selector.

Replication

Just running a normal install

System Details

  • Which version of Local is being used?
    6.30

  • What Operating System (OS) and OS version is being used?
    Windows 10 Education

  • Attach the Local Log. See this Help Doc for instructions on how to do so:
    {“localVersion”:“6.3.0+5756”,“osPlatform”:“win32”,“osRelease”:“10.0.19044”,“windowsEdition”:“Microsoft Windows 10 Education”,“linuxEdition”:null,“level”:“warn”,“message”:“Electron Event ready”,“timestamp”:“2022-03-09T15:11:39.289Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-09T15:21:12.319188Z 0 [System] [MY-010116] [Server] %%resourcesPath%%\lightning-services\mysql-8.0.16+6\bin\win64\bin\mysqld.exe (mysqld 8.0.16) starting as process 2492”,“timestamp”:“2022-03-09T15:21:13.973Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-09T15:21:12.320348Z 0 [Warning] [MY-013243] [Server] --character-set-server: The character set UTF8MB3 is deprecated and will be removed in a future release. Please consider using UTF8MB4 instead.”,“timestamp”:“2022-03-09T15:21:13.973Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-09T15:21:13.945321Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.”,“timestamp”:“2022-03-09T15:21:13.973Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-09T15:21:13.973523Z 0 [System] [MY-010931] [Server] %%resourcesPath%%\lightning-services\mysql-8.0.16+6\bin\win64\bin\mysqld.exe: ready for connections. Version: ‘8.0.16’ socket: ‘’ port: 10005 MySQL Community Server - GPL.”,“timestamp”:“2022-03-09T15:21:13.974Z”}
    {“thread”:“main”,“class”:“WordPressInstaller”,“message”:“Could not fetch latest WordPress version.request to https://api.wordpress.org/core/version-check/1.7/ failed, reason: self signed certificate in certificate chain”,“type”:“system”,“errno”:“SELF_SIGNED_CERT_IN_CHAIN”,“code”:“SELF_SIGNED_CERT_IN_CHAIN”,“level”:“error”,“stack”:“FetchError: request to https://api.wordpress.org/core/version-check/1.7/ failed, reason: self signed certificate in certificate chain\n at ClientRequest. (%%appPath%%\node_modules\node-fetch\lib\index.js:1461:11)\n at ClientRequest.emit (events.js:315:20)\n at TLSSocket.socketErrorListener (_http_client.js:469:9)\n at TLSSocket.emit (events.js:315:20)\n at emitErrorNT (internal/streams/destroy.js:106:8)\n at emitErrorCloseNT (internal/streams/destroy.js:74:3)\n at processTicksAndRejections (internal/process/task_queues.js:80:21)”,“timestamp”:“2022-03-09T15:25:06.199Z”}
    {“thread”:“main”,“class”:“WordPressInstaller”,“message”:“Error checking for latest version of WordPressrequest to https://api.wordpress.org/core/version-check/1.7/ failed, reason: self signed certificate in certificate chain”,“type”:“system”,“errno”:“SELF_SIGNED_CERT_IN_CHAIN”,“code”:“SELF_SIGNED_CERT_IN_CHAIN”,“level”:“error”,“stack”:“FetchError: request to https://api.wordpress.org/core/version-check/1.7/ failed, reason: self signed certificate in certificate chain\n at ClientRequest. (%%appPath%%\node_modules\node-fetch\lib\index.js:1461:11)\n at ClientRequest.emit (events.js:315:20)\n at TLSSocket.socketErrorListener (_http_client.js:469:9)\n at TLSSocket.emit (events.js:315:20)\n at emitErrorNT (internal/streams/destroy.js:106:8)\n at emitErrorCloseNT (internal/streams/destroy.js:74:3)\n at processTicksAndRejections (internal/process/task_queues.js:80:21)”,“timestamp”:“2022-03-09T15:25:06.199Z”}
    {“localVersion”:“6.3.0+5756”,“osPlatform”:“win32”,“osRelease”:“10.0.19044”,“windowsEdition”:“Microsoft Windows 10 Education”,“linuxEdition”:null,“level”:“warn”,“message”:“Electron Event ready”,“timestamp”:“2022-03-11T14:38:45.410Z”}
    {“localVersion”:“6.3.0+5756”,“osPlatform”:“win32”,“osRelease”:“10.0.19044”,“windowsEdition”:“Microsoft Windows 10 Education”,“linuxEdition”:null,“level”:“warn”,“message”:“Electron Event ready”,“timestamp”:“2022-03-14T13:43:06.509Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:44:33.030380Z 0 [System] [MY-010116] [Server] %%resourcesPath%%\lightning-services\mysql-8.0.16+6\bin\win64\bin\mysqld.exe (mysqld 8.0.16) starting as process 6952”,“timestamp”:“2022-03-14T13:44:34.745Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:44:33.042166Z 0 [Warning] [MY-013243] [Server] --character-set-server: The character set UTF8MB3 is deprecated and will be removed in a future release. Please consider using UTF8MB4 instead.”,“timestamp”:“2022-03-14T13:44:34.745Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:44:33.863852Z 0 [System] [MY-010229] [Server] Starting crash recovery…”,“timestamp”:“2022-03-14T13:44:34.745Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:44:33.868490Z 0 [System] [MY-010232] [Server] Crash recovery finished.”,“timestamp”:“2022-03-14T13:44:34.746Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:44:34.607164Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.”,“timestamp”:“2022-03-14T13:44:34.746Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:44:34.651233Z 0 [System] [MY-010931] [Server] %%resourcesPath%%\lightning-services\mysql-8.0.16+6\bin\win64\bin\mysqld.exe: ready for connections. Version: ‘8.0.16’ socket: ‘’ port: 10005 MySQL Community Server - GPL.”,“timestamp”:“2022-03-14T13:44:34.746Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:53:49.993661Z 0 [System] [MY-010116] [Server] %%resourcesPath%%\lightning-services\mysql-8.0.16+6\bin\win64\bin\mysqld.exe (mysqld 8.0.16) starting as process 2680”,“timestamp”:“2022-03-14T13:53:51.659Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:53:50.006852Z 0 [Warning] [MY-013243] [Server] --character-set-server: The character set UTF8MB3 is deprecated and will be removed in a future release. Please consider using UTF8MB4 instead.”,“timestamp”:“2022-03-14T13:53:51.660Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:53:50.855191Z 0 [System] [MY-010229] [Server] Starting crash recovery…”,“timestamp”:“2022-03-14T13:53:51.660Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:53:50.860048Z 0 [System] [MY-010232] [Server] Crash recovery finished.”,“timestamp”:“2022-03-14T13:53:51.660Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:53:51.621005Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.”,“timestamp”:“2022-03-14T13:53:51.661Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:53:51.659884Z 0 [System] [MY-010931] [Server] %%resourcesPath%%\lightning-services\mysql-8.0.16+6\bin\win64\bin\mysqld.exe: ready for connections. Version: ‘8.0.16’ socket: ‘’ port: 10005 MySQL Community Server - GPL.”,“timestamp”:“2022-03-14T13:53:51.661Z”}
    {“thread”:“main”,“reason”:{},“p”:{},“eventId”:“67bad1816e9242839399295550c475c2”,“level”:“warn”,“message”:“Unhandled Rejection.”,“timestamp”:“2022-03-14T13:55:00.257Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:55:56.929382Z 0 [System] [MY-010116] [Server] %%resourcesPath%%\lightning-services\mysql-8.0.16+6\bin\win64\bin\mysqld.exe (mysqld 8.0.16) starting as process 6580”,“timestamp”:“2022-03-14T13:55:58.469Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:55:56.930464Z 0 [Warning] [MY-013243] [Server] --character-set-server: The character set UTF8MB3 is deprecated and will be removed in a future release. Please consider using UTF8MB4 instead.”,“timestamp”:“2022-03-14T13:55:58.469Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:55:58.434163Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.”,“timestamp”:“2022-03-14T13:55:58.469Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T13:55:58.469560Z 0 [System] [MY-010931] [Server] %%resourcesPath%%\lightning-services\mysql-8.0.16+6\bin\win64\bin\mysqld.exe: ready for connections. Version: ‘8.0.16’ socket: ‘’ port: 10005 MySQL Community Server - GPL.”,“timestamp”:“2022-03-14T13:55:58.469Z”}
    {“thread”:“main”,“class”:“WordPressInstaller”,“message”:“Could not fetch latest WordPress version.request to https://api.wordpress.org/core/version-check/1.7/ failed, reason: read ECONNRESET”,“type”:“system”,“errno”:“ECONNRESET”,“code”:“ECONNRESET”,“level”:“error”,“stack”:“FetchError: request to https://api.wordpress.org/core/version-check/1.7/ failed, reason: read ECONNRESET\n at ClientRequest. (%%appPath%%\node_modules\node-fetch\lib\index.js:1461:11)\n at ClientRequest.emit (events.js:315:20)\n at TLSSocket.socketErrorListener (_http_client.js:469:9)\n at TLSSocket.emit (events.js:315:20)\n at emitErrorNT (internal/streams/destroy.js:106:8)\n at emitErrorCloseNT (internal/streams/destroy.js:74:3)\n at processTicksAndRejections (internal/process/task_queues.js:80:21)”,“timestamp”:“2022-03-14T13:57:23.092Z”}
    {“thread”:“main”,“class”:“WordPressInstaller”,“message”:“Error checking for latest version of WordPressrequest to https://api.wordpress.org/core/version-check/1.7/ failed, reason: read ECONNRESET”,“type”:“system”,“errno”:“ECONNRESET”,“code”:“ECONNRESET”,“level”:“error”,“stack”:“FetchError: request to https://api.wordpress.org/core/version-check/1.7/ failed, reason: read ECONNRESET\n at ClientRequest. (%%appPath%%\node_modules\node-fetch\lib\index.js:1461:11)\n at ClientRequest.emit (events.js:315:20)\n at TLSSocket.socketErrorListener (_http_client.js:469:9)\n at TLSSocket.emit (events.js:315:20)\n at emitErrorNT (internal/streams/destroy.js:106:8)\n at emitErrorCloseNT (internal/streams/destroy.js:74:3)\n at processTicksAndRejections (internal/process/task_queues.js:80:21)”,“timestamp”:“2022-03-14T13:57:23.094Z”}
    {“localVersion”:“6.3.0+5756”,“osPlatform”:“win32”,“osRelease”:“10.0.19044”,“windowsEdition”:“Microsoft Windows 10 Education”,“linuxEdition”:null,“level”:“warn”,“message”:“Electron Event ready”,“timestamp”:“2022-03-14T14:00:04.637Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T14:13:42.958210Z 0 [System] [MY-010116] [Server] %%resourcesPath%%\lightning-services\mysql-8.0.16+6\bin\win64\bin\mysqld.exe (mysqld 8.0.16) starting as process 11596”,“timestamp”:“2022-03-14T14:13:44.448Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T14:13:42.959272Z 0 [Warning] [MY-013243] [Server] --character-set-server: The character set UTF8MB3 is deprecated and will be removed in a future release. Please consider using UTF8MB4 instead.”,“timestamp”:“2022-03-14T14:13:44.448Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T14:13:43.675506Z 0 [System] [MY-010229] [Server] Starting crash recovery…”,“timestamp”:“2022-03-14T14:13:44.449Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T14:13:43.680579Z 0 [System] [MY-010232] [Server] Crash recovery finished.”,“timestamp”:“2022-03-14T14:13:44.449Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T14:13:44.414970Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.”,“timestamp”:“2022-03-14T14:13:44.449Z”}
    {“thread”:“main”,“class”:“Process”,“process”:“mysql”,“level”:“warn”,“message”:“2022-03-14T14:13:44.448485Z 0 [System] [MY-010931] [Server] %%resourcesPath%%\lightning-services\mysql-8.0.16+6\bin\win64\bin\mysqld.exe: ready for connections. Version: ‘8.0.16’ socket: ‘’ port: 10005 MySQL Community Server - GPL.”,“timestamp”:“2022-03-14T14:13:44.450Z”}

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @ljordan627 - thanks for using Local to teach your students! That’s awesome.

This is interesting, and I’m wondering if it may be related to a firewall somehow. Local reaches out to fetch the latest WordPress version, which makes me wonder if that fetch succeeds for you and fails for students.

To make sure I understand: All students see WordPress v5.2.x when creating new sites after installing Local? Do students see an option to upgrade WordPress past 5.2 (the latest is v5.9.2)?

Here is my Local instance - this is what I’m referring to by the WordPress upgrade prompt.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.