Local is requesting administrative privileges to modify and trust

Issue Summary

Every time I create a new website, I get a notification that says: “Local is requesting administrative privileges to modify your /etc/hosts file.”

Also, when I press Trust SSL, I get a notification that says: “Local is requesting administrative privileges to trust a certificate.”

Both of those notifications do not open any settings to grant those privileges and I’m the only user/administrator on this PC.

I still can access the website, but if I want to use HTTPS, I have to change it in the WordPress settings and then do a “search and replace”.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

    • It happens for every single website.
  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

    • Yes


  1. I install new website and get this:

  2. Then I press Trust SSL and get this:

I do not use any anti-virus except Windows Defender.

System Details

  • Which version of Local is being used?

    • 6.7.0
  • What Operating System (OS) and OS version is being used?

    • Windows 11 Professional
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Hi @sinshade

Regarding this message: Local is requesting administrative privileges to modify your /etc/hosts file

That is expected behavior since Local will need to access this to be able to update domains and so on. You may need to search on your machine to be able to find and allow Local in the settings. This might help: Help! I'm running into an EPERM error with the hosts file on Windows

As far as trusting we have another help article here that goes into more detail and extra troubleshooting steps, but once you resolve the first piece this might work more seamlessly.

1 Like

Hello @Nick-B,

Thing is, hosts gets updated with the new info anyway:

::1 test.local #Local Site test.local #Local Site
::1 www.test.local #Local Site www.test.local #Local Site

But I still get the notification.

I checked the FAQ post, removed read-only (was minus, not a checkmark) from hosts, and rebooted the PC, but I still get the notification. It pops up every time I add or delete a site.

Hi @sinshade

If that part is only coming up when you add or delete a site, that is still expected behavior. Anytime you add or delete a site Local has to get permission to edit your hosts file and will usually give you a password prompt. So you’re saying it’s coming up but you’re unable to get past it or allowing Local to proceed?

Yes, I get notifications, but I don’t get any prompts, so I’m a bit confused.
Do I have to do something about it or does it get permission behind the scene?

Is it restricting your workflow at all? Are you still able to create/import/delete sites and so on even without taking an action?

Don’t think so. If it’s intended to use search-replace to get HTTPS going, then everything works just fine.

1 Like

Sounds good @sinshade! I don’t have a Windows machine handy to test but if you’re not getting any work blockages from it then you should be set. If you have any other questions or concerns don’t hesitate to reach back out. We are always happy to help!

1 Like

Thanks. Have a nice day :slight_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.