Local Community

Local is requesting administrative privileges

Issue Summary

One or two-sentence summary of the issue.

Local is unable to provision site - error in Windows == Local is requesting administrative privileges to modify your /etc/host file

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

Yes, after the last 3 or 4 updates on Local

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    Unfortunately not, as stated before, since your 3 or 4 updates, I’m unable to create any websites on Windows 10. This is what windows tell me == Local is requesting administrative privileges to modify your /etc/host file

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

Create a new site and follow the prompts.

System Details

  • Which version of Local is being used?
    Version 6.1.4+5521

  • What Operating System (OS) and OS versions are being used?

    • For example macOS Catalina or Windows 10 Professional

Windows 10 Professional

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.
Unable to provision site

1 Like

Local needs needs your permission to edit the Hosts file on your behalf, so you’ll want to allow it to edit that file.

The Hosts file is a file that lets the computer know where to look for a site when you try to access it in a Web Browser.

If you don’t want Local to make edits to this file, you could try using the localhost Router Mode.

The Router Mode feature allows you to choose between using localhost or a human readable site-domain (something like example.local) to access the WordPress site. You can change this setting by navigating to the “Preferences > Advanced > Router Mode” page.

For more info, see this help doc:

If you are still having issues, can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

1 Like

How do I grant Local permission to edit the Host file?

local-lightning.log (32.9 KB)

1 Like

Local should prompt you for elevated privileges to edit that hosts file.

If you aren’t seeing those prompts, then it’s possible that some sort of security feature or antivirus is locking things down.

Usually, issues relating to Local not being able to edit the Hosts file boil down to one of a couple of things.

  1. There’s some sort of Antivirus software preventing Local from updating the Hosts file. Try temporarily deactivating any antivirus software, and if that allows you to “Fix it” then take a look to see if there are any settings within the Antivirus options that would allow Local to make those kinds of changes in the future!

  2. There’s a setting (usually in Windows) that is physically preventing Local from editing the file

Can you take a look at this FAQ post in the Community Forums and let me know if working through those troubleshooting steps fixes things for you?

I didn’t need to do any of the above before a certain update. Now I’m convinced that local is never going to work on Windows 10 again. It doesn’t really matter what you try anymore, it just doesn’t work. I’m sure the Mac guys don’t have the same issues after updates. The updates don’t even help us anymore. Whether we post the error screen or the log files, there’s just no proper solution coming from the developers. It looks like they have given up as well…
BTW, how do I give local admin privileges to the Host file?

1 Like

Adding on what @Ghost_Android said, I tried all the suggested solutions here and on other threads and forums. Nothing works. Everyone points you to standard answers that don’t work. Windows users are simply let down at the moment…

1 Like

You’re right that you typically don’t have to do these things, but they are a good first step in identifying what’s going wrong under a Windows environment.

You’re right that having a *nix flavored operating system means that some things work more seamlessly, but Mac users encounter their own issues during updates.

If none of the solutions that have already been tried are working, can you try completely uninstalling Local and re-installing it? I know that isn’t an elegant solution, but Windows is a finicky OS, with any number of places that things can go wrong, including other user-land software.

Here’s a help doc that goes into more detail about uninstalling Local:

One thing to note – because Local is desktop software, we don’t have any visibility into your specific instance of Local running on your specific machine. Unless you’ve opted in to sharing error-reporting, screenshots and sharing the Local log are the only tools available for troubleshooting this stuff.

If uninstalling and re-installing Local doesn’t solve things for you, can you provide an updated version of the Local log so that we can take a look to see if any of the messages have changed?

Error start site
Unable to Provosion site

I have the following issues. Refer to the attached

local-lightning.log (9.0 KB)
Here is the local-lightning log

Running Windows 11 Pro

Thanks for that Local log! I’m seeing a few errors that match what the screenshot is showing.

It’s interesting that the error is trying to use the double colon – ie this: ::1

That’s the notation for IPv6: https://serverfault.com/a/444557

I wonder if there’s some odd issue with port allocations on this machine?

After uninstalling Local, did you restart the computer before re-installing it?

Also, do you have other processes that are already listening on port 10011? You can find out if something is listening on that port by following the answer in this stackoverflow answer:

I’ve reinstalled Windows 10 and reinstalled Local and tried creating a site again, twice.
The attached is my results…
Error Installing WordPress
Could not update host file

I really don’t know what to do next. Here’s the localhost part

localhost name resolution is handled within DNS itself.

127.0.0.1 localhost

::1 localhost

Your admin user has a space in the name. You cannot use spaces or extended characters in the username.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.