Local is requesting administrative priviliges - macos sonoma

What issue or error are you experiencing?

i cannot create a new site. i get few errors and a notification local wp is requesting administrative priviliges. I have granted all possible permissions in the security and I run the app as the administrator.
in the past the application used to pop up a request for admin password while the creation process was performed, and also during launching or stopping the site. now it doesn’t. just shows errors.
please support.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

when the app runs try to create a new site (any version/variant)

System Details

  • Local Version:
    8.0.0 (apple silicon)
  • Operating System (OS) and OS version:
    macos sonoma 14.0

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

local-lightning.log (30.9 KB)
local-lightning-verbose.log (139.5 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @ketasz

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Do you have any antivirus, security, or firewall applications that could be blocking Local?

More details about troubleshooting this here: Router Mode

Dev tools. Nope
Antivirus and other. Nope
Tried router mode. I get the exact same error.

In order to refresh here and start with a clean slate could you you could try doing a full uninstall/reinstall. The steps would look like this:

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!

Did all this already before asking here for help. The logs are attached as well in the original post. I also disabled apple integrity security in one of the attempts but it hasn’t helped.

Did Local used to work on this machine in the past or was this your first time trying it on here?

If this is an Apple Silicon machine do you have Rosetta 2 installed?

Brand new system. So yes installing Rosetta helped. However I needed to do a forced installation of Rosetta through mac terminal.
For future reference: open terminal → enter: “softwareupdate --install-rosetta” → hit “A” → Installation complete.

Going through the formal mac process doesn’t help as Local does not allow to select Rosetta in the Info panel (If you need to install Rosetta on your Mac - Apple Support)

Thanks Nick!

1 Like

Thank you for the follow up details @ketasz! It’s on our roadmap to have a native install for Apple Silicon in the near future that won’t require this. Glad you’re squared away for now however :green_heart:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.