Local linking to real live site instead of dev.version

Hi community, I am a newbie with Local, just installed it on windows 10.

Setting up a new dev.site worked nicely. Also managed to import one live site to the dev.environment, all without a hitch.

But then I tried with a second site of mine (pulling it down with backWPup, unpacking, zipping and importing into Local). When now clicking on ADMIN or VIEW SITE, it takes me to the real live URL in both cases.

What can I do to solve this? Please help, I love this app and want to use it!

Hi Albus :sparkles:,

Sounds like a search-replace with WP-CLI is what you need! Let me know if this helps Problem of redirecting the local site to online site

Thank you Clay!

But, alas, still no magic:

  • cmd.exe is saying "Error response from daemon: “Container c982a8… is not running”
  • After input of command “wp search-replace…” the message reads “The command “wp” is either spelled wrong or could not be found.”

What seems strange to me is that I do not have these this issues with another site I loaded into Local, using the exact same procedure. The other site folder also had all its paths pointing to the live version, but for some reason Local correctly converted them into .dev

Please help me fix this, if possible.


Ahem, on the attempt descibed above I might have forgotten to first click on “Start Site”.

Now the result is different, but still jinxed. It reads: "Fatal error: Call to a member function do_uploads_dir() on null in /app/public/wp-content/plugins/userpro/index.php on line 59

Based off of Fatal error: Call to a member function do_uploads_dir() on null in /app/public/wp-content/plugins/userpro/index.php on line 59 I’d go ahead remove userpro from wp-content/plugins since it’s throwing a fatal error.

After that, you should be good to run the WP-CLI command. Once that succeeds, you should be able to re-add that plugin (and update or fix it).

Works now, all good. Thank you very much Clay for your help. Greetings from Austria

1 Like