Local Multisite Does Not Work

Issue Summary

I created a multisite WordPress with Local. The french version is principal and english is secondary. Everything went well until I add the appropriate lines into my .htaccess file, the english version of the site is going into an infinite loop.

I know that this topic has been treated with .htaccess issues but I added the few lines below and still have the issue so I’m assuming that it comes from somewhere else.

I also realize that Local says “No” next to Multisite while it isn a multisite installation.

Thanks in advance for your help!

Troubleshooting Questions

  • There is a port conflict with this site’s domain and Local forces me to us localhost when I want to use mydomain.local so it might be related. Maybe not :slight_smile:

  • Here is my .htacess details if needed:

BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]

add a trailing slash to /wp-admin

RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^(wp-(content|admin|includes).) $1 [L]
RewriteRule ^(.
.php)$ $1 [L]
RewriteRule . index.php [L]

END WordPress


  1. I installed local
  2. I activated multisite through wp-config
  3. I added mydomain.local as default (French) and create a new subfile mydomain.local/en as secondary
  4. I added the few lines to wp-config in order to activate the multisite (WordPress didn’t gave my any lines to add regarding my .htaccess file so I found it online…
  5. I can navigate into the french version, when I switch to the english, I get an infinite loop…

System Details

Hi there!

I also tried to remove everything inside my .htaccess but still the same issue :frowning:

Thanks in advance!

Working with WordPress multisites in Local can be tricky, especially if you are importing an existing network. Because there’s often some adjustments that need to be made to the various server configs, it’s usually better to create a multisite in Local from the beginning.

Can you try creating a new, plain multisite? Follow the usual process, but on the third step, select the type of multisite you want to use under “Advanced.”

One thing to note – since you are using the localhost Router Mode, I think you can only use the “subdirectory” option and not the “subdomain” option.

Hey Ben,

Thanks so much for your clarifications! I reinstalled the entire project following your advices and it works!

I was also able to use Site Domains instead of localhost Router Mode but anyways, I was not planning to do subdomain so I’m fine either way :slight_smile:

Have a great evening Sir!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.