Local Router Error v. 2.2.3

When i want to do something it pops this page. I restarted several times the site and it doesn’t work. I even uninstalled the program twice and again it didn’t worked.

Here is the log if it helps: local-by-flywheel.log (16.8 KB)

I’ve been running into this error a lot lately as well on 2.2.3. What I’ve been able to do to “fix” my site is to change the site domain (and enter my password so it can update my hosts file) and then change the site domain back to what it was originally (and enter my password so it can update my hosts file).

My site loads after that.

@krasidankov & @brettshumaker,

Please check the logs folder in your site’s folder for additional clues.

If you wish, feel free to zip up the entire logs folder and then attach it here.

Here it is the logs folder from my site that I am working on.

logs.zip (12.9 KB)



It looks like Local isn’t seeing some of the site files.

Can you try disabling Faster Docker Volumes under Preferences » Advanced?

Once you do that, go ahead and restart the Local Machine by going to Help » Restart Local’s Machine.

Now it says “Unable to connect”. I am using Firefox.

Everything is all right for now.

Hello. Again. I’m struggling with the same problem. First I wanted to install a theme and then activate it. After I click “Activate” it said “Local Router Error”. And now it doesn’t want even to connect. And the process is very slow claiming it can be faster if you work on local machine.

logs.zip (12.2 KB)

I’m having the same issue. For the last 2 days, every time I try to update a theme I get “Local Router Error”. I’ve restarted Local as well as my computer several times and keep getting the same error. I checked the Faster Docker Volumes mentioned above and confirmed that it was already set to off.

I posted this a while ago and never got a response.

I’m still having errors. Especially when I use Local’s Import option and import from a BackupBuddy Zip. Can someone help? Below is the original post. Thanks

I am having these issues and others. I am using the latest install. I’ve tried to not only restart Local, but my browser, and even my computer.

When I try to pull a site that I have on another host, so I can redesign it and then bring it to GFW, I get the Local Router Error/

When I go to update a site in Local, it ‘freezes’ - it does nothing for a long time (10 mins or longer) - and when I close it all out and go back, I get this message: Briefly unavailable for scheduled maintenance. Check back in a minute.

So it thinks it is updating the files still, but never brings the site back up. I try to restart again, and still get this message.

Additionally, a couple of times when I have tried to pull in a site, it creates the site domain as the actual site not a .local version. So it would be yourdomain.com, not yourdomain.local.

When I try to manually correct it, it doesn’t seem to know what to do.

And finally, when I add a site, and it gives me the prompt to click to see the site, it opens tabs to all the live sites, not simply the one I just installed.

I’ve attached my log.

local-by-flywheel.log (88.1 KB)