Local Community

Local Site Fails to Load

Issue Summary

Local site fails to load because of my mistake! I went in the WP settings and change the web site address from http to https and now the site won’t come up in Local!

How do I change the settings in the Wordpress site back to http: ?

Troubleshooting Questions

  • This is the only site that I screwed-up, so far!!!

  • I have other local sites that work fine because I have done this stupid thing to them, yet!

Replication

I’m not going to replicate how I screwed this up. Don’t want anyone else to do the same!

System Details

  • Using Local Version 5.10.3+5332

  • I’m on an Apple iMac using macOS Big Sur ver. 11.2.3

  • Attach the Local Log. See this Community Forum post for instructions on how to do so:

I cannot find any such log file, ie. no local-lightning.log nor a local-by-flywheel.log

Hey @guardsix6

Since you are running BigSur, you might try manually enabling SSL by following the steps in this help doc:

Once that site’s SSL certificate has been trusted in Keychain, you should be able to access the site in a browser.

If you are still having issues and want to revert the site back to the regular HTTP version, the quickest way is probably to use wpcli within the Site Shell. To do this:

  1. Right-click on the site in Local and select “Open Site Shell”
  2. Within the terminal window that opens, issue the search-replace command that should look something like this (use the domain for the site that you set in Local)
wp search-replace 'https://example.local' 'http://example.local'

Can you give either of those things a try and let us know how it goes?

Well, thanks but nothing worked.

I used KeyAccess which happens to be in a “Utilities” folder under Applications on my macOS Big Sur. I ran that, and found several files that ended in .local with certificates. All were already set to Always Trust.

I then opened the site shell and did the wp search-replace ‘https://galactic-library.local’ ‘http://galactic-library.local’ with no luck. The terminal window reports “Success: Made 0 replacements.”

My Local - Local Sites application doesn’t really give me much info on the developmental site I’m working on.

Site Host shows as localhost:10003 which doesn’t mean much when trying to remember the site address.

SSL: “Note! HTTPS is not available when using the localhost Routing Mode”. This shows on every one of my developmental web sites. Is that because I’m not a “Pro” subscriber?

![Local by Flywheel - Chapman|620x499](upload://9Cekkia33I9np8q8D7AHo8kvzjd.jpeg) 

I still can’t access the site. I guess I could just delete this one and start all over. Not sure I want to do that yet.

Any more help?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.