Local Stopped working. All Local Sites are gone, and can't create new ones

Hello, I’m in need of help.
I was starting my work week, and suddenly all my Local Sites were gone. I tried to troubleshoot it, and was happy to find that they were still here, all of them on the folder, just not showing up on Local.

  • Saw that I could create a new website and import the .zip folder. Tried that, didn’t work.
  • Tried creating a new site, and then I would just put the files there, shouldn’t be a big issue. Upon clicking “add site” it just didn’t do anything.
  • Ok, saw that it could be related to the .json file, that It could be empty. I went to check for it and… everything was there, seemed fine no issues.

So, I backed up everything, uninstalled local, rebooted my pc. Installed local again.

  • Still not being able to add site.
  • Ok did everything again but now installed previous version. Still not working.
  • Uninstall - reboot - install in a different disk… Still not working.

I’m running out of ideas and getting more and more frustrated, panic starting to settle. I just want to work

System Details

Intel(R) Core™ i5-10600KF CPU @ 4.10GHz 4.10 GHz

  • Local Version:

  • Operating System (OS) and OS version:
    Windows 10 Pro

Local Logs

Today logs:
local-logs1.zip (1.1 MB)

Logs before doing anything:
local-logs.zip (1.1 MB)

Sorry that you encountered this, @Unhallowed.

You say you’ve already tried re-importing sites. Could you try following these steps, please?

  1. In Windows File Explorer, locate your Local sites here: PC → [your hard drive] → Users → [your username] → Local Sites.
  2. Right click each of your sites folders, and choose “Compress to ZIP file” to make a zip file from each site folder.
  3. Drag each zip file into Local to import it (you may have to give it a new name).

If that doesn’t work, it would be helpful to have exact error messages Local displays when the import fails, as well as a copy of your Local logs immediately following the import attempt.


First one says:

If I try again with a different name, says :

Forgot about logs, here they are:
local-logs3.zip (1.1 MB)

Thanks for sharing your logs, @Unhallowed. Please could you try this?

  1. Quit Local if it’s running.
  2. Open the Windows File Explorer.
  3. Make sure you have enabled “show hidden items”.
  4. Browse to This PC → [your hard drive] → Users → [your username] → AppData → Roaming → Local.
  5. Rename the sites-organization.json file to sites-organization-old.json.
  6. Start Local.

Import the sites manually from their location on disk by zipping them and dragging them into Local as before (you will still need to give them a different name).

1 Like

Hello Nickc!

Okay. They are all back. most of them were giving me issues ( because i changed folder name, removed some, etc ).

But they are back.

Thank you so much Nickc!

1 Like

Man I’m really thankful. I was already passing everything to my laptop, what a relief, you can’t imagine, I had over 30 websites here.

You answered pretty fast, and really straight forward as an easy guide.

Is there anything I can do?

1 Like

Great to hear, @Unhallowed! I’m sorry again that you experienced this. Thank you for reporting the issue and for using Local.

1 Like