Local website is not opening, instead it opens Wampserver

Issue Summary

When I click the VIEW SITE button I get the Wampserver homepage instead of the installed WordPress website, although it was working as expected a week ago!

Troubleshooting Questions

  • It happens to all websites on the local sites

  • I can’t access the WP local site in the browser


System Details

I’m using the latest version

I’m using Windows 10

local-lightning.log (71.1 KB)

There’s also another problem, when I click START SITE button I get the following notice: " Heads-up! Local’s router is having trouble starting."

Local won’t be able to work at the same time that WAMP is turned on. The reason for this is that both programs are trying to use the default port of 80 on the computer. You’ll need to do one of two things:

  1. Only run one of these applications at a time. You’ll want to stop both of them, and then only start one of them for this to work.

  2. Another option is to make use of Local’s localhost Router Mode, which can be found under “Preferences > Advanced > Router Mode”. This will mean that Local doesn’t use the pretty URLs like examplesite.local and will instead use ports that look something like localhost:10015. There are some limitations of this like not being able to use HTTPS for the Local site, but otherwise this should let you run both Local and WAMP at the same time.

For more info on Router Mode, see this help doc: https://localwp.com/help-docs/router-mode/

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.