Both Admin button and open site buttons don't do anything

Issue Summary

Both admin and open site buttons do not open anything

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular? Yes

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser? No


Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used? Windows 10

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
  • Attach the Local Log. See this Community Forum post for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

As an update, infact no buttons on the entire local interface are working. What is going on?

I was experiencing the same thing today and restarting my pc did the trick. Hope it helps!

I’m experiencing the same thing today on my Mac laptop running Big Sur. my Desktop running local 3 is working fine what’s up?

Any help on this issue? I am experiencing the same issue on my Mac version High Sierra version: 10.13.6

I created a new site and the same thing happens. WP version 5.9.1


Hi @gff - this issue has been noted and resolved in another thread.

Please open Local’s preferences and set a default browser to resolve the issue. This will be fixed in our next Local release.

1 Like

After investigating and checking the configuration of the app, I noticed that the default browser was not set. That indeed fixes the issue. I am surprised that it’s not set since I downloaded the version for Mac OS by default it uses Safari. The developers of this app could by default set it to Safari, Internet Explorer for those downloading the app for Microsoft Windows. That’d be a smart thing to do developers.

I just figured this out and was going to post about it but you guys found it out before I did! Granted, I had a family emergency which took me away from work for a few days (it’s all better now, FYI)… but it’s SO nice because I needed to log in to Local in order to turn off Instant Reload and was fairly frustrated because I couldn’t, until I looked at preferences… Anyway, glad it’s both being fixed, and there’s a solution while we wait for the update as well!

~ Tracy

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.