Local wont open - error when updating and the virtual box today


After agreeing to update local by flywheel today, as i had a new version notification, it said there were errors updating local and i now am stuck on the welcome screen where you need to configure virtual box and host machine . I cant click on the radio buttons and even though I allow it to make changes iwhen I click the ‘lets go’ button, it freezes and is completely non responsive… i now cant get in to a number of sites i am developing there, and I hav a meeting shortly with a clinet. aaaaagh help please! :slight_smile:
log file starts going bad here:
Nov 13, 2018, 12:50 PM GMT - warn: [main/docker-machine] Docker machine “local-by-flywheel” does not exist. Use “docker-machine ls” to list machines. Use “docker-machine create” to add a new one.
Nov 13, 2018, 12:50 PM GMT - info: [main/docker-machine] child process exited with code 1
Nov 13, 2018, 12:50 PM GMT - error: [main/docker-machine] Error enabling host DNS resolver for Docker Machine Error: spawnSync C:\Program Files\Oracle\VirtualBox\VBoxManage.exe ENOENT
at _errnoException (util.js:1024:11)
at spawnSync (child_process.js:591:20)
at Object.execFileSync (child_process.js:628:13)
at Object.module.(anonymous function) [as execFileSync] (ELECTRON_ASAR.js:166:20)

and keeps going on like this until it finishes with…

Nov 13, 2018, 12:50 PM GMT - info: [renderer/CheckEnvPage] Check system promise response:
[ ‘virtualbox-not-ready’, ‘machine-does-not-exist’ ]

please can someone help? this is urgent i have 4 important sites on local and clients that need to see them urgently! I am new to flywheel. thanks.

Same here. Local on Windows 10 is broken after updating…

i tried uninstalling both flywheel and virtual box and reinstalling and still the same issue. the router log says it stops at waiting on IP address…I 'm worried i have lost all the sites I have been working on and their is no other way to get support from flywheel it seems.

also there are no log files at all in my local by flywheel logs folder :fearful:

I’m having this same issue! Did you find any solution?

Hey guys, I just got a solution to work for me- you have to update Virtual Box manually. Check this: