LocalWP on Debian problems - Router not running?

What issue or error are you experiencing?

Basically this:

When using LocalWP in “Domain” mode, an error pops up when attempting to start (or add) a site.
While with some hacks sites run in localhost mode, this is not preferable.

What I noticed was a difference in behaviour compared to macOS;
With LocalWP in Domain mode, on macOS, when I ask for a site that is not running, a splash screen is shown that states that fact. On Debian, all I get is the browser error page that says server not responding.

This says to me; the nginx router is not running.

In old versions, we had an option “restart router” – I don’t see that in 7.x.
Also, the Router log stays empty; nothing to report. Clearly there are problems, so empty log says to me; not even an attempt is made at starting the nginx service.

In localhost mode, using nginx as a site preference instead of apache, the same error occurs.

Conclusing: the problem is with the bundled nginx software.

Weird thing is; on Ubuntu 23.04 (a debian derivative), this seemed not to be a problem to my recollection, but It has been a while since I switched to debian 12 and have no running Ubuntu instance to verify.

System Details

  • 7.1.2+6410 (latest .deb as of writing)

  • Linux Debian 12, kernel 6.1.0-11-amd64

Local Logs

local-lightning.zip (14.2 KB)
And as stated; there are no router log files.


In case you missed it, this bug should have been fixed in Local v7.2! Have you been able to update and test it yet?

Running 8.0.0 now, can confirm fixed! (haven’t tried 7.2)

Thank you :slight_smile:

1 Like

Thank you for letting us know @rmpel

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.