Local Community

Lost admin when using "one click admin"

Issue Summary

I have been using a Local site for testing out upgrades etc. and I have the “one click admin” activated.
I’ve not had any problems until yesterday when I made a few revisions to the site and then found that neither the site nor the admin page would open.
I then noticed that in the dropdown for the “one click admin” there wasn’t any amins to choose from?

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    This only happens for one site.

System Details

  • Which version of Local is being used?

I’m using the latest version of Local and the latest version of WordPress.

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @wmwebdes - thanks for reaching out! What happens when you try to open the site in the browser? It doesn’t load, or does it return some error code?

If you start your site and use “Open site shell”, can you try running wp user list to see if any users are returned for the site?

Hi Austin
When I try to open the site, it doesn’t load and there is no error message.
All I get is the spinning wheel in Chrome.

Could you point me in the direction of guidance on “Open site shell”.

Many thanks
Keith Davis

Sure thing! At the top of your screen, under the site name, is the button for “Open site shell”. I took a screenshot here and added a box around it. You’ll want to make sure your site is started first.

This will open a terminal you can run the command in. Here is what my terminal looks like running that command, where you can see I have an administrator user:

@wmwebdes Keith, one more thought - can you share your Local logs? Here is a guide to doing so - Retrieving Local’s Log File - Local

I had another user run into a similar problem, and it was due to a port conflict with the Local site’s database. This prevented the site from loading (and would also prevent users from loading, as they are in the database). My guess is something similar might be happening here!

Hi Austin.

Local log files attached.

Many thanks for your help.

Regards

Keith Davis

WM Web Design

local-logs2.zip (16.3 KB)

Hi Austin

Could you please give me a screenshot of where to run wp user list once the Shell is open?

Regards

Keith Davis

WM Web Design

Hi @wmwebdes - I can see in your error logs a similar issue! Local tries to access your database, which will load your website as well as your list of users, and it can’t because something else is already using that port. Here’s that error I saw:

{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2022-08-05T21:42:57.423190Z 0 [ERROR] [MY-010257] [Server] Do you already have another mysqld server running on port: 10012 ?","timestamp":"2022-08-05T21:42:57.417Z"}

Do you know if you are using localhost or Site Domain routing mode in Local? If you’re on localhost mode, your site will open in your browser at a URL like localhost:10000. If you are on Site Domain mode, it will open in the browser at a URL like mysite.local. There’s more information here if you’re interested - What is Router Mode? - Local

All that to say, we might be able to fix this issue by switching that setting and restarting the site. The help doc linked has a section for changing this setting and a video to walk through it. Can you try that and let me know if it resolves the issue?

Hi Austin

Thanks for staying with this one.

It looks as though I am in “Site Domain Mode”.

If I change to “localhost” my other site (I only have 2 sites running in Local) displays the orange bar with the “fix it” option, but the site I am having problems with doesn’t display the bar and still won’t load.

Any thoughts?

Regards

Keith Davis

WM Web Design

@wmwebdes Hey Keith, no problem - I’m sorry this has been tougher than I thought. Something on your machine must be using the same port Local is trying to use to run the database. For you, that is port 10012. It might be another program, or it could be firewall/antivirus stopping communication on that port for some reason.

Can you try finding (and turning off) whatever is running on that port? Here is a guide to doing so - 3 Ways to Find Which Linux Process Listening on a Port. On Windows, I would recommend using the netstat command in that help doc.