Local Community

Mac - 6.41/Monterey 12.6 Fix: SSL certificate problem: unable to get local issuer certificate

Hi all,

Not sure exactly what caused this error, but something happened and I was getting the
SSL certificate problem: unable to get local issuer certificate all over my website, as well as SSL certs not being verified. I tried switching PHP versions, Local versions, and wasted a ton of time.

Anyways, the fix was helpfully directed by this post:

I ran var_dump(openssl_get_cert_locations()); on my site, which told me the location of my certs:
[24-Sep-2022 19:09:05 UTC] Array ( [default_cert_file] => /usr/local/etc/openssl@1.1/cert.pem [default_cert_file_env] => SSL_CERT_FILE [default_cert_dir] => /usr/local/etc/openssl@1.1/certs [default_cert_dir_env] => SSL_CERT_DIR [default_private_dir] => /usr/local/etc/openssl@1.1/private [default_default_cert_area] => /usr/local/etc/openssl@1.1 [ini_cafile] => [ini_capath] => )

When I went to that first location, /usr/local/etc/ I did not have the openssl@1.1 folder. I only had openssl@3. I duplicated and renamed the folder and it solved my problem… SO easy!

If you don’t have the openssl folder there, you can try to brew install openssl. Probably other ways to resolve this. I am relieved.

Hopefully this helps someone :slight_smile:

1 Like

Congrats on solving the issue! Thank you for taking the time and sharing the solution. :slightly_smiling_face:

1 Like

Hi @jacob700dev - we really appreciate you sharing what worked for you!

Thank you,


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.