Magic Quotes enabled in PHP

I’m currently configuring a theme in WordPress but every time I use a quote in the settings, such as defining the font stack, it saves with the quotes escaped. For example, it’d be \‘Open Sans\’ instead of just ‘Open Sans’.

Reached out to the theme author and am told that it’s an issue with the server, not the theme and that the server has MAGIC QUOTES enabled in PHP.

Any help in where’d I’d disable?

Welcome to the forum! Happy to help.
Can you send me a screenshot of your code? Are you declaring these font-family in PHP or CSS?

Finally, which version of PHP are you using? Try using the ‘preferred’ environment within Local.

I was using the preferred Local environment with nginx but realized Bluehost is using Apache and PHP 5.6 so I’m spinning up a different environment matching that to give a try.

Still, would like to know how to avoid the escaped characters on the preferred environment.

It’s not in the code that I’m seeing this be applied either. It’s in the backend admin area. There is a settings section for which fonts to use in the site where this one instance is popping up.

Let me grab a screenshot.

Magic quotes was deprecated and removed from PHP 5.4, so I’m not sure how this would be active in a newer version of PHP in Local.

Yea that’s what I keep reading so I’m trying to figure this out.

In the meantime, my needs work for setting the fonts without the quotes but still trying to sort out the problem. ¯_(ツ)_/¯