Most Recent Update Broke Plugin Updates

Ever since updating too Version 2.0.3 (2.0.3) no plugins are updating when clicking update in plugin window. Have to manually replace dir’s which is a huge pain - please fix asap or advise how I can fix myself!

1 Like

Having the same issue. Was also unable to update/re-install the theme which completely wrecked the website temporarily. I hope this is fixed soon.

Noticed if you manually update each plugin individually install of checking multiple plugins are updating properly - its a temp fix I suppose.

Thanks, yes I just did this and it works fine for the plugins that just went rogue this morning. Fingers-crossed they get this fixed soon!

Hey all,

Please see Updating Plugins Fails after 2.0.1 Upgrade

Good find! This should definitely help with tracking down the issue.

2.0.6 is now available via auto-updater. Updating to 2.0.6 will bring in the fix in 2.0.5 for this issue.

Remember to restart any sites affected by this.

Look, even v2.0.8 doesn’t fix things and my plugins, one of them is broken…it’s in the directory but it won’t show on the plugins page at the admin…


Can you please try the following?

  1. Quit Local if it’s running
  2. Open Terminal
  3. Run /Applications/Local\ by\ stop local-by-flywheel
  4. Run VBoxManage modifyvm local-by-flywheel --natdnshostresolver1 on
  5. Run VBoxManage modifyvm local-by-flywheel --natdnsproxy1 on
  6. Re-open Local and check the site

Looks like problem solved…I’ll have to save these codes in case my
students may need them…thanks

1 Like

Update - After restarting Local I hadn’t noticed but the plugins directory had been deleted :thinking:, I recreated it manually via command line and running install works now.

I’ve tried your suggested fix but still seem to be getting a Could not create directory error when trying to install a plugin. eg:

I’ve also disabled faster docker volumes. Running Version 2.0.8