My site breaks on live link, only the front page loads (71.3 KB)

Apple M3 Pro, 2023 Sonoma 14

I have tried all the possible solutions to reinstall, installing the site in different ways, I have tried Apache and ngix, with localhost, the site works perfectly without live link, but when you launch it to live link it breaks, it only loads the frontpage and sometimes loads resources from other sources not

Hi @juliancre

When you say it “breaks” does that mean it loads but certain assets aren’t loading like fonts, images or styling?

We have some troubleshooting steps here for Live Links that might be helpful:

Hi Nick ,Thank you very much for responding, I tried this and it seems to work wp search-replace ‘SITEURL’ ‘LOCALURL’ --skip-columns=guid, but will I always have to do it? (It could be that my site has a lot of resources and the response time sometimes gives me a 404)

It’s tough to say. Generally just doing it once will help clean things up but this can vary depending on how much work you’re doing. If you have plugins or themes that hold cache or have Regenerate CSS options those might need to be flushed as well.

The solution to this (wp search-replace ‘SITEURL’ ‘LOCALURL’ --skip-columns=guid). It worked only once and then the website broke again, I tried everything again and it didn’t work again, Cors errors and (server responded with a status of 404) appear, and the close tunnel button is always rolling, you always have to force it. leaving home to make another attempt

Depending on your Router Mode it might be that certain assets are trying to securely/insecurely. For example Localhost only supports HTTP, so if you have assets that are trying to load via HTTPS that might be an issue. You can try switching to Site Domains Router Mode and then running a search and replace to update any content that’s still loading insecurely. First make sure the Local site is Trusted in the app (there is a toggle on your main page). Then your search and replace command would look like:

wp search-replace http://domain.local https://domain.local --all-tables

Good morning Nick, thank you for your answers, I tried it, it didn’t work, many problems. At this point I was a little frustrated, the only thing that worked was installing the relative url pluing and now it is running fine. for my other smaller sites I don’t need to install it

1 Like

I’m glad to hear your other smaller sites are working as intended and that the plugin solution helped out. Thank you for updating here in case others run into similar issues.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.