My site says 502 Bad Gateway when I tried starting it up

What issue or error are you experiencing?

I updated Local and everything worked yesterday. Today, when I go to my local site, it says 502 Bad Gateway. I am using Windows operating system.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:

  • Operating System (OS) and OS version:

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @mrdurham

Have you tried restarting your machine?

What Windows version are you on? For example 10, 11

Can you share your local log? Retrieving Local’s Log File (71.6 KB)

Hi Nick-B

I restarted my machine and that did not help.
I am using Windows 10.

I have attached the log to this message.

Do you have any antivirus, security, or firewall applications that could be blocking Local? It looks like from the log it might be having trouble connecting.

More details about troubleshooting this here: Router Mode

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

I use Windows Defender but I dont think it is causing problems.

I switched the router mode from Site Domains to localhost but that did not help/.

I am not using any apps like MAMP, XAMPP, or Docker.

If you create a new, blank site in Local and open it do you get a 502 error?

I created a new site and I did not get the 502 error.

You might try reimporting the site that is erroring with steps like this:

  • Right click the site and select Export and save the zip file on your desktop
  • Delete the site from Local
  • Restart the Local app/your machine
  • Open Local back up and drag and drop the zip file back into the app to reimport it and see if it works now

I exported the site and deleted it and also restarted and reimported the site and now everything works. Thank you!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.