502 Bad Gateway error on all current Local sites

What issue or error are you experiencing?

I’m getting a 502 Bad Gateway error on all Local sites. I have tried exporting/deleting/re-importing, PHP downgrades/upgrades, Local/system restarts. Router changes (localhost/domain). Nothing helps. New sites seem to work fine.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Open any current Local site - all give the same error
New sites work fine

System Details

  • Local Version: 8.2.0

  • Operating System (OS) and OS version: macOS Sonoma 14.2.1

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

local-lightning-verbose.log (41.4 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @JoshH

Are you using any addons like Instant Reload? Can you disable/deactivate those and see if that makes a difference?

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

How many sites do you have that aren’t opening?

As a potential workaround you could manually migrate the files into a new site that’s working:

If you’re still having trouble please share your full local log with us. There are some different ways to access and share Local Logs. For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

I’m experiencing the same issue with Local 8.2.0+6554 (no add-ons) and MacOS 14.2.1

If you create a new, blank site in Local can you access that okay? If you can, then you may want to try reimporting the site getting the errors. The steps would look like this:

  • Locate the site files on your machine, and save a copy of them to your desktop. If you click Go to Site Folder under your site name it should take you right to where they are located.
  • Once you have those copied, completely delete the site from Local
  • Restart Local/your machine
  • Reimport the site back into Local. You can refer here on how to Restore from only Local site files

Thanks Nick. I’m still troubleshooting, but I’m fairly confident at this point that my issue is theme/plugin-specific. I am able to create new sites without a problem and I have a few older sites running fine as well.

1 Like

My issue was caused by a missing underscore in one of the locale translations in our theme.

Not sure why it wasn’t an issue until this recent OS update… but I’m tired of thinking about it.

1 Like

Glad you were able to root out a culprit @justin_at_osa! Thank you for coming back and sharing. :green_heart:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.