No Extension None of the supported PHP extensions (MySQLi, MySQL, PDO_MySQL) are available

Where is the “Create New Connection” button? Thank you

1 Like

Same here post migration from v3.x.x

1 Like

Getting this error with v5.2.3+2248.
I cannot run v3.3 anymore because it no longer works after running v5. Also, it overwrote my database files in v5, so I lost entire databases. Another HUGE gripe with v5 is that it ONLY EXPORTS/SAVES/READS the local database.

I do NOT use the ‘local’ database. I either ignore it, or delete it altogether. My database is named differently. BUT v5 Won’t Let me use a differently named database.
Worse: after running v5, the ONLY time it loaded and let me run v3 after that, it DELETED My databases upon stopping any site that I could get it to stop for. Or maybe it deleted them when starting the site??
I could not even get it to stop all sites properly.
Eventually I had to force close Local by Flywheel.
In the end, several sites not longer have MY database in their sql directory.
AND Local By Flywheel v3.3 WILL NOT LONGER START…
So I have NO way of accessing those databases even through MySQL Workbench. :anger: :angry: :angry:

I don’t often use Admirner, as I usually use MySQL Workbench instead. But I’m troubled that the Admirner link does not work in Local v5+.

Had the same problem with the new updates (5.2.3, 5.2.4, and now 5.2.5+2498) in Windows 10. I had to use DBeaver instead.

1 Like

Same here with 5.2.5+2498 in Windows 10

This error appears because you dont properly install php module, for ubuntu its:
sudo apt install php7.4-mysql
its required even if you install mariadb already.
After that it will work as a charm

First time user, clean instal, new site: has this problem on win 10, Local ver 5.2.5+2498

Possible hint to devs: install asks for admin permissions to instal several times, is it possible they were answered “out of sequence” causing partly bad instal?

Temporary Solution:
as per dineshpilani above (thankyou) with a couple of extra hints

Download from adminer: download file from
I used the MySQL one as had selected MySQL when creating new site in Local

rename (not essential) from “adminer-4.7.6-MySQL.php” to easier say: “adminer.php”

copy php file to your local site directory:
Win 10 found mine in:
C:/Users > myUserName > Local Sites > mySiteName(created in Local) > app > public

browse to adminer login page with: mySiteName.local/adminer.php
(Fields likely to be root, root, local) or keep reading …

Your username, password and database information can be accessed via
your “Local” control page > click on mySiteName, right hand side shows “overview” etc, go to Database tab, use Database name / Username / password (default likely to be local root root) to log into Adminer (note order change: User/ password / Database )

PS love the easy remote access in Local, thankyou devs

I’ve updated Local to version 5.0.6+976. Now I have “Open Adminer” under Databse tab, but when I click it I get Adminer screen with “No extension” and “None of the supported PHP extensions (MySQLi, MySQL, PDO_MySQL) are available.” under it. I’m running Local on Windows 10.

I’m seeing this behavior also. Thanks!

@Oly0909 @greggdavis,

Thanks for the bug report.

Does this happen on brand-new sites in addition to existing sites?

Thanks for returning Adminer back to manage the databases in the latest release yesterday 3rd October, however, when accessing it I’m getting an error message:

No Extension
None of the supported PHP extensions (MySQLi, MySQL, PDO_MySQL) are available.

The site is created using Local and I’m using Windows 10

Screenshot of the Error

Screenshot of Local


Heads-up, I moved your post into this topic.

Please see my question here: Adminer gives No extension message on Windows

1 Like

Thanks for replays.
I just created new site and same thing happen when I click “Open Adminer”, so… just doesn’t work.

First site for me. I do have Xampp as well installed now, earlier I tried to work with MAMP but later uninstalled it and kept Xampp. Not sure if this causes any conflict in the ports, I did change the ports in Xampp to unused ones though.

I was able to reproduce the issue and devised a fix. The next update will include said fix. :slight_smile:

Thanks everyone for the information!

I Installed 5.0.7 version, but i receive this error “None of the supported PHP extensions (MySQLi, MySQL, PDO_MySQL) are available”.
and also when i click view site and admin buttons not showing the output.
check the images.


how to rectify this.

1 Like

Hi @manojvs62665,

The 404 error and IIS splash screen (1st and 3rd screenshots) are caused by a conflict with IIS, you will need to either:

As far as the Adminer error goes, we are still gathering details on this since we’re unable to reproduce the issue on our end.

If you have time, we’d appreciate it if you could do the following to help us troubleshoot the Adminer issue:

  1. Click on the “Adminer” button in the “Database” tab

  2. Open Command Prompt (Cmd.exe)

  3. Run WMIC path win32_process get Commandline | findstr php.exe

  4. Copy and paste or screenshot the output
    It should look something like the following:

C:\Windows\System32>WMIC path win32_process get Commandline | findstr php.exe
“C:\Program Files (x86)\Local_Flywheel\resources\extraResources\lightning-services\php-7.3.5+3\bin\win32\php.exe” -S -d memory_limit=256M -d upload_max_filesize=1G -d post_max_size=1G -d sys_temp_dir=C:/Users/sh/AppData/Local/Temp/local-adminer-8q0wHip2W-676786 -d pcre.jit=0 -d session.save_path=C:/Users/sh/AppData/Local/Temp/local-adminer-8q0wHip2W-676786 -d “zend_extension=C:/Program Files (x86)/Local_Flywheel/resources/extraResources/lightning-services/php-7.3.5+3/bin/win32/ext/php_xdebug.dll” -d “extension=C:/Program Files (x86)/Local_Flywheel/resources/extraResources/lightning-services/php-7.3.5+3/bin/win32/ext/php_mysqli.dll” -d “extension=C:/Program Files (x86)/Local_Flywheel/resources/extraResources/lightning-services/php-7.3.5+3/bin/win32/ext/php_pdo_mysql.dll”
“C:\Program Files (x86)\Local_Flywheel\resources\extraResources\lightning-services\php-7.3.5+3\bin\win32\php.exe” -S -d memory_limit=256M -d upload_max_filesize=1G -d post_max_size=1G -d sys_temp_dir=C:/Users/sh/AppData/Local/Temp/local-adminer-Goei5Epgt-770887 -d pcre.jit=0 -d session.save_path=C:/Users/sh/AppData/Local/Temp/local-adminer-Goei5Epgt-770887 -d “zend_extension=C:/Program Files (x86)/Local_Flywheel/resources/extraResources/lightning-services/php-7.3.5+3/bin/win32/ext/php_xdebug.dll” -d “extension=C:/Program Files (x86)/Local_Flywheel/resources/extraResources/lightning-services/php-7.3.5+3/bin/win32/ext/php_mysqli.dll” -d “extension=C:/Program Files (x86)/Local_Flywheel/resources/extraResources/lightning-services/php-7.3.5+3/bin/win32/ext/php_pdo_mysql.dll”
C:\Users\sh\AppData\Roaming\Local\lightning-services\php-5.6.39+3\bin\win32\php.exe -S -d memory_limit=256M -d upload_max_filesize=1G -d post_max_size=1G -d sys_temp_dir=C:/Users/sh/AppData/Local/Temp/local-adminer-xoKottrKP-535897 -d pcre.jit=0 -d session.save_path=C:/Users/sh/AppData/Local/Temp/local-adminer-xoKottrKP-535897 -d zend_extension=C:/Users/sh/AppData/Roaming/Local/lightning-services/php-5.6.39+3/bin/win32/ext/php_xdebug.dll -d extension=C:/Users/sh/AppData/Roaming/Local/lightning-services/php-5.6.39+3/bin/win32/ext/php_mysqli.dll -d extension=C:/Users/sh/AppData/Roaming/Local/lightning-services/php-5.6.39+3/bin/win32/ext/php_pdo_mysql.dll
findstr php.exe

Oddly, Admirner link works for 1 site, but not 2 others. Surprisingly, it does not even work for the TestLocal5 site that I created using all of your default settings, and did not modify anything after creation, that I can recall. That site lives somewhere in the ~ folder, and I did not attempt to get it to use any database other than ‘local’. It is completely untouched.
The 1 site where the admirner link does work lives in a dedicated folder on a different drive, outside Windows path, and I had tried to get it to use MY DATABASE name, user, and password, as I was able to do in v3.
It’s heavily modified - WordPress files are in a subdirectory, etc.
Basically I copied my public folder over from v3, and eventually loaded a backup of my custom database into local, since v3 REFUSES to READ/EXPORT/SAVE any database not named local in v5, even though I can see it in MySQL Workbench, and the website will work with MY database - UNTIL I STOP the site in Local v5. When I restart the website though, it no longer recognizes my database. Even if I put a copy of my database into the sql folder, it will not read it in. MySQL sees my database, but Local does not.

Anyway for the Adminer link: 1 site in my location works. 1 does not. 1 (only) site in your location does not work.

Fortunately, I have MySQL Workbench already, and usually use that.
But the handiness of a link is nice, and the “fallback” in case I had trouble with Workbench should be reassuring.

  1. I have no idea what IIS is. Let alone how to disable it.
  2. When I changed the setting to “localhost”:
  • website no longer loaded, because it’s configured to use https.
    (in fact, the ability to use https is why I go to the trouble to use Local)

  • Adminer still did NOT work. Same error.

Getting the message “No extension. None of the supported PHP extensions (MySQLi, MySQL, PDO_MySQL) are available.” After I hit Open Adminer. I see that there was the same issue here - . So don’t know why I’m getting it now. I’m on version 5.0.7+1117.

My Adminer seems to be 4.7.3 and I see that there’s a 4.7.5 . But I don’t know how to update that. I tried using the directions mentioned here -, but get the message ‘mv’ is not recognized as an internal or external command.

I just want to get into the database. Is there another way?

1 Like