None of my sites start after upgrading to 2.3.2 from 2.3.x Pre-release

@clay, I tried re-installing 2.3.1 and I could never get an existing site to open and run. I didn’t try to create a new site. I don’t have time to debug right now, going out of town for a few days.

Fortunately re-installing 2.3.1 works. I’m happy to help figure this out when I get back.

To be clear, to install or re-install different versions of Local, all I do is swap the Local by Flywheel.app. I’m currently at VB Version 5.2.12 r122591 (Qt5.6.3)

@afragen Oh, I didn’t know we could just swap the exe file…sounds much easier than what I was doing which was uninstalling the program then resintalling the other version (which has the huge downside of having to reconnect all my sites manually).

@clay Is it OK to do it this way, as afragen described?

Got it. Can you send me the log file? Feel free to PM or e-mail it.

Have a nice trip!

Yup! See How do I manually upgrade Local? - FAQ - Local Community

How do you “uninstall” on OS X? I usually just delete the app. Do I need to remove other files as well?

Thank you.

Maybe I’m confused… it sounded like @afragen was just swapping out the exe that launches the program in the install directory to quickly jump back and forth between versions, not running again the downloaded file that runs the setup (which is what I’ve been doing and which is desribed in your link). So maybe I misunderstood @afragen’s method to quickly go back and forth between versions.

@daniel,

See How do I uninstall Local on macOS?


@metrosuperstar,

Andy is on macOS. The steps to manually upgrade are different on macOS and Windows.

On macOS, you upgrade by swapping out Local by Flywheel.app in /Applications. On Windows, all you have to do is download and run the latest installer.

Ok, thank you. (Note that I don’t actually want to remove the app - I was just wondering for eventual upgrade… I usually just copy the new app over the old one. I want to upgrade to environment 1.3.0, but I’m going to wait and see what becomes of these issues.)

Thanks again!
Daniel

1 Like

Hey everyone, I see we are all having the same type of issue. I just posted what worked for me here. Start with the bottom step of logging out and then back in first to see if that helps you.

I posted it here

I’m joining the club… Ever since the update, and updating the environment to 1.3 from 1.2 I cannot connect to the clone (it starts) and I get errors pointing to the router log… The original without the updated environment doesn’t even start. I’m stuck between two nowhere places…
local-by-flywheel.log (13.8 KB)

Here’s my router log as well.
error.log (668.5 KB)

Same here - updated to version 2.3.2 not one single site can start and I can’t even upgrade to environment 1.3.0 since it can’t find any mysql (container not started)
Downgraded to version 2.3.1-prerelease - and restartet it all - and after some restarting of sites all is now working again.

Hope this will be fixed soon so ver. 2.3.2 is working correctly

Agreed. Would be nice to get a timeline for the fix…

I worked out a fix myself… Works a treat. Read here

I’ve experienced the same after upgrading to 2.3.2 on MacOS High Sierra, this works for me:
export all the sites to zip, manually delete all the sites present in Local, complete uninstallation of the app, remove the virtualbox container, reinstall and import those zips back, voila.

Alright, since I started this thread, I thought I’d contribute my own fix, which is for WIN 10. This is for creating new sites if you are not being successful. (or reconnecting old ones from Local Sites with their structure intact)

2%20Bug%20WORKAROUND%20-%20Step%2022%20Bug%20WORKAROUND%20-%20Step%2032%20Bug%20WORKAROUND%20-%20Step%204

@clay
NOTE. The method above was done with Fast Docker Volumes and IPV6 Loopback turned off. When I tried enabling FAST DOCKER VOLUMES and IPV6 LOOPBACK on this after the sites were up and running, it created a non-stop loop of restarting the running websites, so I had to eventually EXIT the app. When I tried the sites again, I was back to 502 Error. I had to EXIT again. This time after restarting the local machine, they were working again, with Fast Docker and IPV6 Loopback enabled. Not sure if I did something wrong here by turning on Fast Docker WHILE some sites were running or if this is part of the bug…

I have left Fast Docker and IPV6 on for subsequent site creations/reconnections since I will be using these features. That was not an issue but I still had to use the above fix, regardless of whether the site was being setup with these options enabled or disabled.

If anyone is having this issue, please let us know what operating system you’re running, what Environment(s) your sites are running, and what web server(s) if Custom.

Also, please provide the logs folder for any sites that aren’t responding.

So sorry for the trouble!

1 Like

Win 10 latest (v1803)
Custom 1.3 as Apache PHP 7.1.4 SQL 5.6
Fast Docker and IPV6 Enabled
Workaround being used right now and everything seems fine, but will feel more relaxed when a patch is released :wink:

I see a lot of Windows mentioned in this thread (no hate, just observation). Has anyone experienced issues with 2.3.2 on OS X (High Sierra)?

Thank you in advance,
Daniel

I’m on OS X High Sierra.